diff mbox series

[bug#45601,2/2] gnu: vlang: Use system picoenv.

Message ID 20210104014620.19614-3-rprior@protonmail.com
State Under Review
Headers show
Series Another vlang dependency plucked out (re: bug#45601) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Prior Jan. 4, 2021, 1:46 a.m. UTC
* gnu/packages/vlang.scm (vlang): Use system picoenv.
---
 gnu/packages/vlang.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index dd970e643a..c3f439fce6 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -24,6 +24,7 @@ 
   #:use-module (gnu packages javascript)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
+  #:use-module (gnu packages networking)
   #:use-module (gnu packages node)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
@@ -74,6 +75,7 @@ 
          (for-each delete-file-recursively
                    '("thirdparty/bignum"
                      "thirdparty/cJSON"
+                     "thirdparty/picoev"
                      "thirdparty/wyhash"))))))
    (build-system gnu-build-system)
    (arguments
@@ -102,7 +104,10 @@ 
                (assoc-ref inputs "cJSON")))
             (substitute* "vlib/hash/wyhash.c.v"
               (("@VROOT/thirdparty/wyhash")
-               (string-append (assoc-ref inputs "wyhash") "/include")))))
+               (string-append (assoc-ref inputs "wyhash") "/include")))
+            (substitute* "vlib/picoev/picoev.v"
+              (("@VROOT/thirdparty/picoev")
+               (string-append (assoc-ref inputs "picoev") "/include")))))
         (add-before 'build 'patch-cc
           (lambda _
             (let* ((bin "tmp/bin")
@@ -164,6 +169,7 @@ 
     `(("glib" ,glib)
       ("tiny-bignum" ,tiny-bignum)
       ("cJSON" ,(package-source cjson))
+      ("picoev" ,picoev)
       ("wyhash" ,wyhash)))
    (native-inputs
     `(("vc"