diff mbox series

[bug#45624] gnu: Added python-mutagen to gpodder

Message ID 20210102195721.657749a8@riseup.net
State Accepted
Headers show
Series [bug#45624] gnu: Added python-mutagen to gpodder | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Jan. 2, 2021, 6:57 p.m. UTC
This is necessary for the tagging addon to find mutagen. There is
probably a way to have gpodder load modules from the environment, but I
don't have time to figure that out right now.

Comments

Efraim Flashner July 20, 2021, 6:42 p.m. UTC | #1
On Sat, Jan 02, 2021 at 07:57:21PM +0100, raingloom wrote:
> This is necessary for the tagging addon to find mutagen. There is
> probably a way to have gpodder load modules from the environment, but I
> don't have time to figure that out right now.

This patch seems to have fallen through the cracks. Patch pushed!
diff mbox series

Patch

From e1cf53fa05ba59186d00f84331910d6e1bd00e97 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sat, 2 Jan 2021 19:41:13 +0100
Subject: [PATCH] gnu: Added python-mutagen to gpodder (fixes one of its
 addons).

* gnu/packages/gpodder.scm (gpodder)[inputs]: Added python-mutagen.
---
 gnu/packages/gpodder.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 44c356e2ff..9d1604f515 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -29,6 +29,7 @@ 
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages music)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -62,6 +63,7 @@ 
        ("python-html5lib" ,python-html5lib)
        ("python-mygpoclient" ,python-mygpoclient)
        ("python-podcastparser" ,python-podcastparser)
+       ("python-mutagen" ,python-mutagen)
        ("youtube-dl" ,youtube-dl)
        ("xdg-utils" ,xdg-utils)))
     (arguments
-- 
2.29.2