diff mbox series

[bug#45604,1/1] Added magic-enum header-only library as a package.

Message ID 20210102005145.582428-2-joshua.r.marshall.1991@gmail.com
State Accepted
Headers show
Series Add magic-enum package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Anadon Jan. 2, 2021, 12:51 a.m. UTC
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>

---
 gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Leo Prikler Jan. 4, 2021, 1:06 p.m. UTC | #1
Hello Anadon,

I have not yet built your package (because I'm currently also handling
another patch), but since you've requested review over at guix-devel,
I'll have a go at it.
For the future please note, that a delay of 2 days does not mean we
haven't noticed you at all.  The manual has the following to say for
committers:
> For anything else, please post to <guix-patches@gnu.org> and leave
> time for a review, without committing anything (*note Submitting
> Patches::).  If you didn’t receive any reply after two weeks, and if
> you’re confident, it’s OK to commit.

Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
> From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Ehh, somehow the commit message and everything is missing here.  Is
that intended or just misconfigured?

> ---
>  gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
> 
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index 00e006928e..ff10a4247b 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -807,3 +807,27 @@ code will be mixed in with the actual
> programming logic.  This implementation
>  provides a number of utilities to make coding with expected
> cleaner.")
>      (home-page "https://tl.tartanllama.xyz/")
>      (license license:cc0)))
> +
> +(define-public magic-enum
> +    (package
> +      (name "magic-enum")
> +      (version "0.7.2")
> +      (home-page "https://github.com/Neargye/magic_enum")
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url home-page)
> +                      (commit (string-append "v" version))))
> +                (sha256
> +                 (base32
> +                  "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> sv2"))
> +                (modules '((guix build utils)))))
> +      (build-system cmake-build-system)
> +
> +      (inputs
> +       `(("gcc" ,gcc-10)))
The home-page claims, that it works with GCC>=9.  Have you encountered
any issues with gcc-9 instead?
> +      (synopsis "Header-only C++17 library for reflection for
> enums")
I feel as though that could be worded better.
> +      (description "Static reflection for enums (to string, from
> string,
> +iteration) for modern C++, work with any enum type without any macro
> or
> +boilerplate code")
Descriptions should be complete sentences and end with a period.
> +      (license license:expat)))

Regards,
Leo
Anadon Jan. 4, 2021, 9:59 p.m. UTC | #2
Sorry, one more thing I missed in the documentation was the waiting
period.  The commit message missing is probably a misconfiguration.  I can
change to gcc-9, I just defaulted to the newest since the default was too
old.  That description is a verbatim copy of their description.

I'll fix these up, then issue another patch series.







On Mon, Jan 4, 2021 at 8:06 AM Leo Prikler <leo.prikler@student.tugraz.at>
wrote:

> Hello Anadon,
>
> I have not yet built your package (because I'm currently also handling
> another patch), but since you've requested review over at guix-devel,
> I'll have a go at it.
> For the future please note, that a delay of 2 days does not mean we
> haven't noticed you at all.  The manual has the following to say for
> committers:
> > For anything else, please post to <guix-patches@gnu.org> and leave
> > time for a review, without committing anything (*note Submitting
> > Patches::).  If you didn’t receive any reply after two weeks, and if
> > you’re confident, it’s OK to commit.
>
> Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
> > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
> Ehh, somehow the commit message and everything is missing here.  Is
> that intended or just misconfigured?
>
> > ---
> >  gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> >  1 file changed, 24 insertions(+)
> >
> > diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> > index 00e006928e..ff10a4247b 100644
> > --- a/gnu/packages/cpp.scm
> > +++ b/gnu/packages/cpp.scm
> > @@ -807,3 +807,27 @@ code will be mixed in with the actual
> > programming logic.  This implementation
> >  provides a number of utilities to make coding with expected
> > cleaner.")
> >      (home-page "https://tl.tartanllama.xyz/")
> >      (license license:cc0)))
> > +
> > +(define-public magic-enum
> > +    (package
> > +      (name "magic-enum")
> > +      (version "0.7.2")
> > +      (home-page "https://github.com/Neargye/magic_enum")
> > +      (source (origin
> > +                (method git-fetch)
> > +                (uri (git-reference
> > +                      (url home-page)
> > +                      (commit (string-append "v" version))))
> > +                (sha256
> > +                 (base32
> > +                  "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> > sv2"))
> > +                (modules '((guix build utils)))))
> > +      (build-system cmake-build-system)
> > +
> > +      (inputs
> > +       `(("gcc" ,gcc-10)))
> The home-page claims, that it works with GCC>=9.  Have you encountered
> any issues with gcc-9 instead?
> > +      (synopsis "Header-only C++17 library for reflection for
> > enums")
> I feel as though that could be worded better.
> > +      (description "Static reflection for enums (to string, from
> > string,
> > +iteration) for modern C++, work with any enum type without any macro
> > or
> > +boilerplate code")
> Descriptions should be complete sentences and end with a period.
> > +      (license license:expat)))
>
> Regards,
> Leo
>
>
Leo Prikler Jan. 5, 2021, 8:39 p.m. UTC | #3
Hello Josh,
Am Montag, den 04.01.2021, 16:59 -0500 schrieb Josh Marshall:
> Sorry, one more thing I missed in the documentation was the waiting
> period.  The commit message missing is probably a misconfiguration. 
> I can change to gcc-9, I just defaulted to the newest since the
> default was too old.  That description is a verbatim copy of their
> description.
W.r.t. the description you should probably come up with words of your
own.  The upstream one doesn't appear all that usable.

For the record, gcc should likely also be a native-input, given that
it'll be used for compilation and testing.

> I'll fix these up, then issue another patch series.
Don't forget to set --to, --cc and --reroll-count when you do ;)
Otherwise you might inadvertently open up new issues which will at
least confuse the bug tracker.

Regards,
Leo

> On Mon, Jan 4, 2021 at 8:06 AM Leo Prikler <
> leo.prikler@student.tugraz.at> wrote:
> > Hello Anadon,
> > 
> > I have not yet built your package (because I'm currently also
> > handling
> > another patch), but since you've requested review over at guix-
> > devel,
> > I'll have a go at it.
> > For the future please note, that a delay of 2 days does not mean we
> > haven't noticed you at all.  The manual has the following to say
> > for
> > committers:
> > > For anything else, please post to <guix-patches@gnu.org> and
> > leave
> > > time for a review, without committing anything (*note Submitting
> > > Patches::).  If you didn’t receive any reply after two weeks, and
> > if
> > > you’re confident, it’s OK to commit.
> > 
> > Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
> > > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
> > Ehh, somehow the commit message and everything is missing here.  Is
> > that intended or just misconfigured?
> > 
> > > ---
> > >  gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> > >  1 file changed, 24 insertions(+)
> > > 
> > > diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> > > index 00e006928e..ff10a4247b 100644
> > > --- a/gnu/packages/cpp.scm
> > > +++ b/gnu/packages/cpp.scm
> > > @@ -807,3 +807,27 @@ code will be mixed in with the actual
> > > programming logic.  This implementation
> > >  provides a number of utilities to make coding with expected
> > > cleaner.")
> > >      (home-page "https://tl.tartanllama.xyz/")
> > >      (license license:cc0)))
> > > +
> > > +(define-public magic-enum
> > > +    (package
> > > +      (name "magic-enum")
> > > +      (version "0.7.2")
> > > +      (home-page "https://github.com/Neargye/magic_enum")
> > > +      (source (origin
> > > +                (method git-fetch)
> > > +                (uri (git-reference
> > > +                      (url home-page)
> > > +                      (commit (string-append "v" version))))
> > > +                (sha256
> > > +                 (base32
> > > +                 
> > "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> > > sv2"))
> > > +                (modules '((guix build utils)))))
> > > +      (build-system cmake-build-system)
> > > +
> > > +      (inputs
> > > +       `(("gcc" ,gcc-10)))
> > The home-page claims, that it works with GCC>=9.  Have you
> > encountered
> > any issues with gcc-9 instead?
> > > +      (synopsis "Header-only C++17 library for reflection for
> > > enums")
> > I feel as though that could be worded better.
> > > +      (description "Static reflection for enums (to string, from
> > > string,
> > > +iteration) for modern C++, work with any enum type without any
> > macro
> > > or
> > > +boilerplate code")
> > Descriptions should be complete sentences and end with a period.
> > > +      (license license:expat)))
> > 
> > Regards,
> > Leo
> >
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..ff10a4247b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@  code will be mixed in with the actual programming logic.  This implementation
 provides a number of utilities to make coding with expected cleaner.")
     (home-page "https://tl.tartanllama.xyz/")
     (license license:cc0)))
+
+(define-public magic-enum
+    (package
+      (name "magic-enum")
+      (version "0.7.2")
+      (home-page "https://github.com/Neargye/magic_enum")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit (string-append "v" version))))
+                (sha256
+                 (base32
+                  "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+                (modules '((guix build utils)))))
+      (build-system cmake-build-system)
+
+      (inputs
+       `(("gcc" ,gcc-10)))
+      (synopsis "Header-only C++17 library for reflection for enums")
+      (description "Static reflection for enums (to string, from string,
+iteration) for modern C++, work with any enum type without any macro or
+boilerplate code")
+      (license license:expat)))