diff mbox series

[bug#45601,5/6] gnu: vlang: Use system wyhash.

Message ID 20210101192713.23655-5-rprior@protonmail.com
State Under Review
Headers show
Series vlang 0.2 update | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Prior Jan. 1, 2021, 7:27 p.m. UTC
* gnu/packages/vlang.scm (vlang) Use system wyhash.
---
 gnu/packages/vlang.scm | 15 +++++++++++----
 1 file changed, 11 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index db7438d7f7..92d178a3e1 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -19,6 +19,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages vlang)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
@@ -63,8 +64,10 @@ 
      (snippet
       '(begin
          ;; Eventually remove the whole thirdparty directory.
-         (delete-file-recursively "thirdparty/bignum")
-         (delete-file-recursively "thirdparty/cJSON")))))
+         (for-each delete-file-recursively
+                   '("thirdparty/bignum"
+                     "thirdparty/cJSON"
+                     "thirdparty/wyhash"))))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags
@@ -89,7 +92,10 @@ 
                (string-append (assoc-ref inputs "tiny-bignum") "/share")))
             (substitute* "vlib/json/json_primitives.v"
               (("@VROOT/thirdparty/cJSON")
-               (assoc-ref inputs "cJSON")))))
+               (assoc-ref inputs "cJSON")))
+            (substitute* "vlib/hash/wyhash.c.v"
+              (("@VROOT/thirdparty/wyhash")
+               (string-append (assoc-ref inputs "wyhash") "/include")))))
         (add-before 'build 'patch-cc
           (lambda _
             (let* ((bin "tmp/bin")
@@ -150,7 +156,8 @@ 
    (inputs
     `(("glib" ,glib)
       ("tiny-bignum" ,tiny-bignum)
-      ("cJSON" ,(package-source cjson))))
+      ("cJSON" ,(package-source cjson))
+      ("wyhash" ,wyhash)))
    (native-inputs
     `(("vc"
        ;; Versions are not consistently tagged, but the matching commit will