diff mbox series

[bug#45565,1/2] gnu: Add r-mlr3pipelines.

Message ID 20201231125341.1287-1-wz@freeshell.de
State Accepted
Headers show
Series Add more r-mlr3 add-ons | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Dec. 31, 2020, 12:53 p.m. UTC
* gnu/packages/cran.scm (r-mlr3pipelines): New variable.
---
 gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 40f8e82c34..0837ddaf87 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25575,3 +25575,34 @@  tuning, e.g. Grid Search, Random Search, or Simulated Annealing.  Various
 termination criteria can be set and combined.  The class @code{AutoTuner} provides a
 convenient way to perform nested resampling in combination with @code{mlr3}.")
     (license license:lgpl3)))
+
+(define-public r-mlr3pipelines
+  (package
+    (name "r-mlr3pipelines")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mlr3pipelines" version))
+              (sha256
+               (base32
+                "1x738b312mcvb0dif88sv4nlh3y6i47q0wagc5ggyh1hnqjiz71y"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-backports" ,r-backports)
+       ("r-checkmate" ,r-checkmate)
+       ("r-data-table" ,r-data-table)
+       ("r-digest" ,r-digest)
+       ("r-lgr" ,r-lgr)
+       ("r-mlr3" ,r-mlr3)
+       ("r-mlr3misc" ,r-mlr3misc)
+       ("r-paradox" ,r-paradox)
+       ("r-r6" ,r-r6)
+       ("r-withr" ,r-withr)))
+    (home-page "https://mlr3pipelines.mlr-org.com/")
+    (synopsis "Preprocessing Operators and Pipelines for @code{mlr3}")
+    (description "@code{mlr3pipelines} enriches @code{mlr3} with a diverse
+set of pipelining operators (PipeOps) that can be composed into graphs.
+Operations exist for data preprocessing, model fitting, and ensemble learning.
+Graphs can themselves be treated as @code{mlr3} Learners and can therefore be
+resampled, benchmarked, and tuned.")
+    (license license:lgpl3)))