diff mbox series

[bug#45551] gnu: Add erofs-utils.

Message ID 20201230094335.14334-1-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#45551] gnu: Add erofs-utils. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Dec. 30, 2020, 9:43 a.m. UTC
* gnu/packages/linux.scm (erofs-utils): New variable.
---
 gnu/packages/linux.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Leo Famulari Dec. 31, 2020, 5:56 a.m. UTC | #1
On Wed, Dec 30, 2020 at 10:43:35AM +0100, pukkamustard wrote:
> * gnu/packages/linux.scm (erofs-utils): New variable.

Thanks!

> +       (uri (git-reference
> +             (url "git://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git")

I changed it to use an HTTPS address instead of git://

We prefer HTTPS because the connection is authenticated and it provides
some degree of privacy. Additionally, its port (443) is more likely to
be allowed than the port used by the Git protocol (9418).

> +    (inputs
> +     `(("lz4" ,lz4)
> +       ("util-linux" ,util-linux "lib")))

I also changed the "label" of the util-linux dependency to "libuuid", to
communicate more clearly what util-linux is being used for.

Pushed as 764fbd0abcbfffc9302554f264e14777cb18815e
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 99ad2b421c..4991849dc5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -52,6 +52,7 @@ 
 ;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
+;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7745,3 +7746,32 @@  helpers to setup and teardown io_uring instances, and also a simplified
 interface for applications that don't need (or want) to deal with the full
 kernel side implementation.")
     (license license:expat)))
+
+(define-public erofs-utils
+  (package
+    (name "erofs-utils")
+    (version "1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "git://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07hvijq2hsn3gg1kb8abrfk23n83j57yx8kyv4wqgwhhvd30myjc"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("lz4" ,lz4)
+       ("util-linux" ,util-linux "lib")))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git/")
+    (synopsis "User-space tools for EROFS filesystem")
+    (description "EROFS (Enhanced Read-Only File System) is a compressed,
+read-only filesystem optimized for resource-scarce devices.  This package
+provides user-space tools for creating EROFS filesystems.")
+    (license license:gpl2+)))