diff mbox series

[bug#45534,4/5] Add r-paradox

Message ID 20201229124121.3369-4-wz@freeshell.de
State Accepted
Headers show
Series gnu: Add r-mlr3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Dec. 29, 2020, 12:41 p.m. UTC
gnu: Add r-paradox.

* gnu/packages/cran.scm (r-paradox): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 527412b365..3604ebd06b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25460,3 +25460,28 @@  helper functions for functional programming, for printing, to work with
 @code{data.table}, as well as some generally useful @code{R6} classes.  This
 package also supersedes the package @code{BBmisc}.")
     (license license:lgpl3)))
+
+(define-public r-paradox
+  (package
+    (name "r-paradox")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "paradox" version))
+              (sha256
+               (base32
+                "1zv0q411wcwigkf4yggs3w2gz48lvv3jhnrddrv40qih8b70ywi3"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-backports" ,r-backports)
+       ("r-checkmate" ,r-checkmate)
+       ("r-data-table" ,r-data-table)
+       ("r-mlr3misc" ,r-mlr3misc)
+       ("r-r6" ,r-r6)))
+    (home-page "https://paradox.mlr-org.com/")
+    (synopsis "Define and work with parameter spaces for complex algorithms")
+    (description "With this package it is possible to define parameter spaces,
+constraints and dependencies for arbitrary algorithms, and to program on such
+spaces.  It also includes statistical designs and random samplers.  Objects are
+implemented as @code{R6} classes.")
+    (license license:lgpl3)))