diff mbox series

[bug#45531] gnu: hdf5: Update to 1.12.0.

Message ID 20201229121203.5353-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45531] gnu: hdf5: Update to 1.12.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Dec. 29, 2020, 12:12 p.m. UTC
* gnu/packages/maths.scm (hdf5): Update to 1.12.0.
---
 gnu/packages/maths.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Dec. 30, 2020, 2:19 a.m. UTC | #1
On Tue, Dec 29, 2020 at 01:12:03PM +0100, Vincent Legoll wrote:
> * gnu/packages/maths.scm (hdf5): Update to 1.12.0.

Thanks!

>  (define-public hdf5-1.10
>    (package/inherit hdf5-1.8
> -    (version "1.10.7")
> +    (version "1.12.0")

The variable name should be updated to reflect the new version, and any
packages using it would also need to be adjusted.

Can you send a revised patch?
Vincent Legoll Dec. 30, 2020, 4:01 p.m. UTC | #2
Hello,

On Wed, Dec 30, 2020 at 3:19 AM Leo Famulari <leo@famulari.name> wrote:
> >  (define-public hdf5-1.10
> >    (package/inherit hdf5-1.8
> > -    (version "1.10.7")
> > +    (version "1.12.0")
>
> The variable name should be updated to reflect the new version, and any
> packages using it would also need to be adjusted.

oops,completely missed that, sorry.

> Can you send a revised patch?

Yep, I'll do.

Thanks for the review
Simon Tournier Dec. 30, 2020, 6:34 p.m. UTC | #3
Hi,

On Wed, 30 Dec 2020 at 17:01, Vincent Legoll <vincent.legoll@gmail.com> wrote:
> On Wed, Dec 30, 2020 at 3:19 AM Leo Famulari <leo@famulari.name> wrote:

>> >  (define-public hdf5-1.10
>> >    (package/inherit hdf5-1.8
>> > -    (version "1.10.7")
>> > +    (version "1.12.0")
>>
>> The variable name should be updated to reflect the new version, and any
>> packages using it would also need to be adjusted.
>
> oops,completely missed that, sorry.

Please check that all the packages depending on hdf5-1.10 correctly
build with 1.12.0, for example: freecad, libmedfile, etc.

And also hdf5-parallel-openmpi which inherits from, so packages
depending on that too.

Therefore, instead it could be simpler to add a new variable hdf5-1.12
and use it as default with the variable hdf5.


All the best,
simon
Vincent Legoll Jan. 5, 2021, 9:34 a.m. UTC | #4
Hello,

On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
> Please check that all the packages depending on hdf5-1.10 correctly
> build with 1.12.0, for example: freecad, libmedfile, etc.
>
> And also hdf5-parallel-openmpi which inherits from, so packages
> depending on that too.

Is this specific to that package or should I always rebuild all the
dependencies (& their dependencies) for each package update ?
Efraim Flashner Jan. 5, 2021, 12:32 p.m. UTC | #5
On Tue, Jan 05, 2021 at 10:34:36AM +0100, Vincent Legoll wrote:
> Hello,
> 
> On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
> > Please check that all the packages depending on hdf5-1.10 correctly
> > build with 1.12.0, for example: freecad, libmedfile, etc.
> >
> > And also hdf5-parallel-openmpi which inherits from, so packages
> > depending on that too.
> 
> Is this specific to that package or should I always rebuild all the
> dependencies (& their dependencies) for each package update ?
> 

The packages which share a source should definitely be tested out. As
far as ones that depend on them test them out to your best ability. It
normally depends on computing power and whether they built previously or
not.

Some package groups have special needs. rust packages only really need
to pass their build phase, and anything that depends on them should just
keep working. I've never gotten a good result from java packages so I'll
build those out to the very end. Due to the way python works it can be
hit-or-miss.
Simon Tournier Jan. 6, 2021, 6:38 p.m. UTC | #6
Hi,

On Tue, 05 Jan 2021 at 10:34, Vincent Legoll <vincent.legoll@gmail.com> wrote:
> On Wed, Dec 30, 2020 at 7:35 PM zimoun <zimon.toutoune@gmail.com> wrote:
>> Please check that all the packages depending on hdf5-1.10 correctly
>> build with 1.12.0, for example: freecad, libmedfile, etc.
>>
>> And also hdf5-parallel-openmpi which inherits from, so packages
>> depending on that too.
>
> Is this specific to that package or should I always rebuild all the
> dependencies (& their dependencies) for each package update ?

I do not know if there is a rule.  But hdf5 is used by many scientific
packages and so changing the default version needs some care, IMHO.
Upgrading the version could lead to annoying breakages and it is better
to fix them at this upgrading time than to discover them later.

Well, I am not sure about your initial intention with your patch,

 a) add the new variable hdf5-1.12
 b) change the variable hdf5-1.10 by hdf5-1.12 which means replace all
 the occurrences of hdf5-1.10 and check everything builds; note the
 default hdf5 is changed too so it is a lot of rebuilds

Some packages specifically depends on hdf5-1.8 so maybe some packages
also specifically require hdf5-1.10; I have not checked.

These 9 packages specifically use hdf5-1.10:

        hdf5-parallel-openmpi, freecad, libmedfile, hdf5-blosc,
        python-h5py, python-tables, sbcl-hdf5-cffi, r-rhdf5lib,
        sra-tools

so they need special care, at least. :-)

My point is “guix refresh -l hdf5” says the upgrade could have an impact
on a couple of packages and I just wanted be sure that you were aware of
that. :-)


All the best,
simon
Vincent Legoll Jan. 7, 2021, 8:40 a.m. UTC | #7
Hello,

Thanks for the explanation, I'll see if I can build
those & report here.
Vincent Legoll Jan. 11, 2021, 5:57 p.m. UTC | #8
Hello,

I tried to make it the default, but at least ecl-hdf5-cffi
did not rebuild properly, so I think the best way forward
would be to add 1.12.0 as a separate non-default version,
and then let the users of the dependent packages update
as they want / have tested. I'm not user of any of those...

Or completely drop my (random-)update.
Simon Tournier Jan. 14, 2021, 12:38 p.m. UTC | #9
Hi Vincent,

Thank you for testing.

On Mon, 11 Jan 2021 at 18:57, Vincent Legoll <vincent.legoll@gmail.com> wrote:

> I tried to make it the default, but at least ecl-hdf5-cffi
> did not rebuild properly, so I think the best way forward
> would be to add 1.12.0 as a separate non-default version,
> and then let the users of the dependent packages update
> as they want / have tested. I'm not user of any of those...

This was my initial suggestion. :-)
On the other hand, if only one package is failing with 1.12.0, maybe
upgrade the default and keep the previous for this specific package
only.

All the best,
simon
Vincent Legoll Feb. 21, 2021, 9:29 p.m. UTC | #10
Closing as duplicate of :
f601cdc6981888f55882c942dab413cb783caecc
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b54cd6dff1..09e0837872 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1200,7 +1200,7 @@  extremely large and complex data collections.")
 
 (define-public hdf5-1.10
   (package/inherit hdf5-1.8
-    (version "1.10.7")
+    (version "1.12.0")
     (source
      (origin
        (method url-fetch)
@@ -1214,7 +1214,7 @@  extremely large and complex data collections.")
                                         (take (string-split version #\.) 2))
                                  "/src/hdf5-" version ".tar.bz2")))
        (sha256
-        (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
+        (base32 "0qazfslkqbmzg495jafpvqp0khws3jkxa0z7rph9qvhacil6544p"))
        (patches (search-patches "hdf5-config-date.patch"))))))
 
 (define-public hdf5