diff mbox series

[bug#45524] gnu: tigervnc-client: Update to 1.11.0.

Message ID 20201229103557.7018-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45524] gnu: tigervnc-client: Update to 1.11.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Dec. 29, 2020, 10:35 a.m. UTC
* gnu/packages/vnc.scm (tigervnc-client): Update to 1.11.0.
[inputs]: Add pixman.
---
 gnu/packages/vnc.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Leo Famulari Dec. 30, 2020, 8:04 a.m. UTC | #1
On Tue, Dec 29, 2020 at 11:35:57AM +0100, Vincent Legoll wrote:
> * gnu/packages/vnc.scm (tigervnc-client): Update to 1.11.0.
> [inputs]: Add pixman.

Thanks!

> -  (let ((commit "920d9c4d6562ecabf79497bc901d50522d4bc661"))
> +  (let ((commit "540bfc3278e396321124d4b18a798ac2bc18b6ca"))

> +      (version (git-version "1.11.0" "0" commit))

I noticed that this commit was the 1.11.0 release tag, so I changed it
to use (version "1.11.0")

Pushed as 776c700aafb380ffc72f10cc463c6dfeb35dd7c1
Vincent Legoll Dec. 30, 2020, 3:55 p.m. UTC | #2
On Wed, Dec 30, 2020 at 9:04 AM Leo Famulari <leo@famulari.name> wrote:
> I noticed that this commit was the 1.11.0 release tag, so I changed it
> to use (version "1.11.0")

Yes, I hesitated just doing so myself...

> Pushed as 776c700aafb380ffc72f10cc463c6dfeb35dd7c1

Thanks
Leo Famulari Dec. 30, 2020, 8:17 p.m. UTC | #3
On Wed, Dec 30, 2020 at 04:55:36PM +0100, Vincent Legoll wrote:
> On Wed, Dec 30, 2020 at 9:04 AM Leo Famulari <leo@famulari.name> wrote:
> > I noticed that this commit was the 1.11.0 release tag, so I changed it
> > to use (version "1.11.0")
> 
> Yes, I hesitated just doing so myself...

Feel free in the future :)

In general, it's always welcome to simplify the packages.
Oleg Pykhalov Jan. 1, 2021, 9:09 a.m. UTC | #4
Hello,

I reverted the update to 1.11.0, because it breaks tigervnc-server
(missing /gnu/store/...-tigervnc-server-1.11.0/bin/tigervnc-server
binary).

Oleg.
Oleg Pykhalov Jan. 1, 2021, 9:47 a.m. UTC | #5
Unfortunately, upstream breaks users scripts by intention without
warnings in the previos stable release 1.10.1 about deprecating ‘bin’
directory for ‘vncserver’ in next release, and mention this in release
news [1]:

  vncserver has gotten a major redesign to be compatible with modern
  distributions

[1] https://github.com/TigerVNC/tigervnc/releases/tag/v1.11.0

Apologies for missing that.  I reverted the package downgrade to 1.10.1.

Oleg.
Leo Famulari Jan. 1, 2021, 6:46 p.m. UTC | #6
On Fri, Jan 01, 2021 at 12:47:26PM +0300, Oleg Pykhalov wrote:
> Unfortunately, upstream breaks users scripts by intention without
> warnings in the previos stable release 1.10.1 about deprecating ‘bin’
> directory for ‘vncserver’ in next release, and mention this in release
> news [1]:
> 
>   vncserver has gotten a major redesign to be compatible with modern
>   distributions
> 
> [1] https://github.com/TigerVNC/tigervnc/releases/tag/v1.11.0
> 
> Apologies for missing that.  I reverted the package downgrade to 1.10.1.

Thanks for paying attention and taking care of it!
diff mbox series

Patch

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index ab89bad7aa..9aac5dfea8 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,13 +42,14 @@ 
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))
 
 (define-public tigervnc-client
-  (let ((commit "920d9c4d6562ecabf79497bc901d50522d4bc661"))
+  (let ((commit "540bfc3278e396321124d4b18a798ac2bc18b6ca"))
     (package
       (name "tigervnc-client")
-      (version (git-version "1.10.1" "1" commit))
+      (version (git-version "1.11.0" "0" commit))
       (source (origin
                 (method git-fetch)
                 (uri
@@ -56,7 +58,7 @@ 
                   (commit commit)))
                 (sha256
                  (base32
-                  "1lp6mxl5dqlkrzx0q145jzgpbwvhsni3fj6x9ngf8v5s63x82q1p"))
+                  "1bg79ahr4mzy48ak0caxy3ckdsxmhpchypggaz6lxjjk92hgsz91"))
                 (file-name (git-file-name name version))))
       (build-system cmake-build-system)
       (arguments
@@ -80,7 +82,8 @@ 
          ("libxext" ,libxext)
          ("libxtst" ,libxtst)
          ("libxrandr" ,libxrandr)
-         ("libxdamage" ,libxdamage)))
+         ("libxdamage" ,libxdamage)
+         ("pixman" ,pixman)))
       (home-page "https://tigervnc.org/")
       (synopsis "High-performance, platform-neutral
 implementation of VNC (client)")