@@ -2441,4 +2441,64 @@ as phones, embedded computers or microcontrollers.")
;; Dual licensed.
(license (list license:epl1.0 license:edl1.0))))
+(define-public zulip-term
+ (package
+ (name "zulip-term")
+ (version "0.5.2")
+ (source
+ (origin
+ ;; Pypi package doesn't ship tests.
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/zulip/zulip-terminal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xhhy3v4wck74a83avil0rnmsi2grrh03cww19n5mv80p2q1cjmf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete failing tests.
+ (delete-file "tests/cli/test_run.py")
+ (substitute* "setup.py"
+ (("\\=\\=1\\.7") ">=1.7")
+ (("\\=\\=2\\.5") ">=2.5"))
+ #t))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest")
+ #t))))))
+ (propagated-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-dateutil" ,python-dateutil)
+ ("python-lxml" ,python-lxml-for-zulip-term)
+ ("python-urwid" ,python-urwid)
+ ("python-urwid-readline" ,python-urwid-readline)
+ ("python-zulip" ,python-zulip)))
+ (native-inputs
+ `(("python-distro" ,python-distro)
+ ("python-flake8" ,python-flake8)
+ ("python-flake8-continuation"
+ ,python-flake8-continuation)
+ ("python-flake8-quotes" ,python-flake8-quotes)
+ ("python-isort" ,python-isort)
+ ("python-mypy" ,python-mypy)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-snakeviz" ,python-snakeviz)
+ ("python-zipp" ,python-zipp)))
+ (home-page
+ "https://github.com/zulip/zulip-terminal")
+ (synopsis "Zulip's official terminal client")
+ (description "Zulip's official terminal client")
+ (license license:asl2.0)))
+
;;; messaging.scm ends here
@@ -2323,3 +2323,16 @@ XML data to JSON and other formats.")
(description "This package provides a Python library to convert XML to
@code{OrderedDict}.")
(license license:expat)))
+
+;; This is only for zulip-term
+(define-public python-lxml-for-zulip-term
+ (package
+ (inherit python-lxml)
+ (version "4.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lxml" version))
+ (sha256
+ (base32
+ "1xhx76hr1w3lllfcg9a01f2y0zwyf59ijnvlh08299mjh8b3mhfd"))))))