diff mbox series

[bug#45514,6/8] gnu: Add python-snakeviz.

Message ID 20201228213245.12577-6-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#45514,1/8] gnu: python-urwid: Update to 2.1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Dec. 28, 2020, 9:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-snakeviz): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Efraim Flashner April 1, 2021, 12:15 p.m. UTC | #1
Thanks for the patch and my apologies for taking so long to get around
to it.

This patch has some minimized javascript in the snakeviz/vendor
directory which needs to be unbundled. I don't know how useful the
package is with it removed instead of replaced, but here's the snippet
from the 'unpack phase

snakeviz-2.1.0/snakeviz/static/vendor/
snakeviz-2.1.0/snakeviz/static/vendor/d3.v3.min.js
snakeviz-2.1.0/snakeviz/static/vendor/immutable.min.js
snakeviz-2.1.0/snakeviz/static/vendor/jquery-3.2.1.min.js
snakeviz-2.1.0/snakeviz/static/vendor/jquery.dataTables.min.css
snakeviz-2.1.0/snakeviz/static/vendor/jquery.dataTables.min.js
snakeviz-2.1.0/snakeviz/static/vendor/lodash.min.js
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bbb425ae8..8a00bebe3e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23303,3 +23303,28 @@  These should be used in preference to using a backslash for line continuation.
     (synopsis "Flake8 lint for quotes.")
     (description "This package provides a Flake8 lint for quotes.")
     (license license:expat)))
+
+(define-public python-snakeviz
+  (package
+    (name "python-snakeviz")
+    (version "2.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "snakeviz" version))
+       (sha256
+        (base32
+         "0s6byw23hr2khqx2az36hpi52fk4v6bfm1bb7biaf0d2nrpqgbcj"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-tornado" ,python-tornado)))
+    (home-page
+     "https://jiffyclub.github.io/snakeviz/")
+    (synopsis
+     "Web-based viewer for Python profiler output")
+    (description
+     "SnakeViz is a browser based graphical viewer for
+the output of Python’s cProfile module and an alternative to
+using the standard library pstats module.
+It was originally inspired by RunSnakeRun. ")
+    (license license:bsd-3)))