diff mbox series

[bug#45514,5/8] gnu: Add python-flake8-quotes.

Message ID 20201228213245.12577-5-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#45514,1/8] gnu: python-urwid: Update to 2.1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Dec. 28, 2020, 9:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-quotes): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e7ed416367..1bbb425ae8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23283,3 +23283,23 @@  can be broken over multiple lines by wrapping expressions in parentheses.
 These should be used in preference to using a backslash for line continuation.
 @end quotation")
     (license license:asl2.0)))
+
+(define-public python-flake8-quotes
+  (package
+    (name "python-flake8-quotes")
+    (version "3.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-quotes" version))
+       (sha256
+        (base32
+         "0ph5s6lxgpzz4an0ax6s5xjqypqmngwr5b1i0h9pqhzghplic49z"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-flake8" ,python-flake8)))
+    (home-page
+     "http://github.com/zheller/flake8-quotes/")
+    (synopsis "Flake8 lint for quotes.")
+    (description "This package provides a Flake8 lint for quotes.")
+    (license license:expat)))