diff mbox series

[bug#45498,v2,13/13] gnu: ocaml-yojson: Make dependencies propagated-inputs.

Message ID 20201228181414.14196-13-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#45498,v2,01/13] gnu: Remove ocaml-js-build-tools. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Dec. 28, 2020, 6:14 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-yojson): Make dependencies propagated-inputs.
---
 gnu/packages/ocaml.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 258f7e8fd6..f3f275046f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3857,7 +3857,7 @@  than yojson), with 25-35% space savings.")
     (build-system dune-build-system)
     (arguments
      `(#:test-target "."))
-    (inputs
+    (propagated-inputs
      `(("ocaml-biniou" ,ocaml-biniou)
        ("ocaml-easy-format" ,ocaml-easy-format)))
     (native-inputs
@@ -3928,11 +3928,7 @@  format}.  @code{craml} is released as a single binary (called @code{craml}).")
     (inputs
      `(("ocaml-yojson" ,ocaml-yojson)
        ("ocaml-csexp" ,ocaml-csexp)
-       ("ocaml-result" ,ocaml-result)
-       ;; XXX: following are dependencies of ocaml-yojson. Should they be
-       ;; propagated-inputs in ocaml-yojson?
-       ("ocaml-biniou" ,ocaml-biniou)
-       ("ocaml-easy-format" ,ocaml-easy-format)))
+       ("ocaml-result" ,ocaml-result)))
     (home-page "https://ocaml.github.io/merlin/")
     (synopsis "Reads config files for @code{ocaml-merlin}")
     (description "@code{ocaml-dot-merlin-reader} is an external reader for
@@ -3958,8 +3954,6 @@  format}.  @code{craml} is released as a single binary (called @code{craml}).")
                  #:test-target "tests"))
     (inputs
      `(("ocaml-yojson" ,ocaml-yojson)
-       ("ocaml-biniou" ,ocaml-biniou)
-       ("ocaml-easy-format" ,ocaml-easy-format)
        ("ocaml-csexp" ,ocaml-csexp)
        ("ocaml-result" ,ocaml-result)))
     (native-inputs
@@ -3994,9 +3988,7 @@  Atom.")
           "15ssgmwdxylbwhld9p1cq8x6kadxyhll5bfyf11dddj6cldna3hb"))))
      (build-system dune-build-system)
      (inputs
-      `(("ocaml-biniou" ,ocaml-biniou)
-        ("ocaml-yojson" ,ocaml-yojson)
-        ("ocaml-easy-format" ,ocaml-easy-format)))
+      `(("ocaml-yojson" ,ocaml-yojson)))
      (native-inputs
       `(("ocaml-findlib" ,ocaml-findlib)))
      (arguments