diff mbox series

[bug#45501] gnu: crypto++: Update to 8.3.0.

Message ID 20201228141737.718-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45501] gnu: crypto++: Update to 8.3.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Dec. 28, 2020, 2:17 p.m. UTC
* gnu/packages/crypto.scm (crypto++): Update to 8.3.0.
---
 gnu/packages/crypto.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Vincent Legoll Dec. 28, 2020, 2:19 p.m. UTC | #1
Hello,

could someone try this update and report if
the test suite passes properly.

It hangs forever in my guix VM (which has
rng-tools and is passing entropy from the host)

Thanks
Efraim Flashner Jan. 2, 2021, 9:44 p.m. UTC | #2
On Mon, Dec 28, 2020 at 03:19:51PM +0100, Vincent Legoll wrote:
> Hello,
> 
> could someone try this update and report if
> the test suite passes properly.
> 
> It hangs forever in my guix VM (which has
> rng-tools and is passing entropy from the host)
> 

No issue here on bare metal. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 1b51366d7e..85378850ff 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -717,7 +717,7 @@  data on your platform, so the seed itself will be as random as possible.
 (define-public crypto++
   (package
     (name "crypto++")
-    (version "8.2.0")
+    (version "8.3.0")
     (source (origin
               (method url-fetch/zipbomb)
               (uri (string-append "https://cryptopp.com/cryptopp"
@@ -725,7 +725,7 @@  data on your platform, so the seed itself will be as random as possible.
                                   ".zip"))
               (sha256
                (base32
-                "0n40hlz5jkvlcp9vxrj0fsrcfp7dm0zmmv6h52dx3f8i5qjf5w03"))))
+                "16jqxvsyjjpyyb89fj2h8mgb0m07vlqvggifbrk7qcqwddda2f6v"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags