diff mbox series

[bug#45500] gnu: borg: Install shell completions.

Message ID 20201228133622.13253-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#45500] gnu: borg: Install shell completions. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Dec. 28, 2020, 1:36 p.m. UTC
* gnu/packages/backup.scm (borg)[arguments]: Add phase to install shell completions.
---
 gnu/packages/backup.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Leo Famulari Dec. 30, 2020, 10:55 p.m. UTC | #1
On Mon, Dec 28, 2020 at 02:36:22PM +0100, Michael Rohleder wrote:
> * gnu/packages/backup.scm (borg)[arguments]: Add phase to install shell completions.

Thanks! Pushed as 9d6863de245fc061f24693b58ce87e73fe299d31
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 892b92dc2f..0db2c47b2d 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -670,6 +671,19 @@  detection, and lossless compression.")
                            "docs/misc/internals-picture.txt"
                            "docs/misc/prune-example.txt"))
                (copy-recursively "docs/man" man)
+               #t)))
+         (add-after 'install-docs 'install-shell-completions
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (etc (string-append out "/etc"))
+                    (share (string-append out "/share")))
+               (with-directory-excursion "scripts/shell_completions"
+                 (install-file "bash/borg"
+                               (string-append etc "/bash_completion.d"))
+                 (install-file "zsh/_borg"
+                               (string-append share "/zsh/site-functions"))
+                 (install-file "fish/borg.fish"
+                               (string-append share "/fish/vendor_completions.d")))
                #t))))))
     (native-inputs
      `(("python-cython" ,python-cython)