diff mbox series

[bug#45470] gnu: redis: Update to 6.0.9.

Message ID 20201227164945.10190-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45470] gnu: redis: Update to 6.0.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Dec. 27, 2020, 4:49 p.m. UTC
* gnu/packages/databases.scm (redis): Update to 6.0.9.
---
 gnu/packages/databases.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Dec. 28, 2020, 3:44 p.m. UTC | #1
I see there are a number of bundled libraries, included jemalloc,
linenoise and lua. Can we unbundle them? And is there some subset of the
tests we can run?
Vincent Legoll Dec. 28, 2020, 3:47 p.m. UTC | #2
On Mon, Dec 28, 2020 at 4:45 PM Efraim Flashner <efraim@flashner.co.il> wrote:
> I see there are a number of bundled libraries, included jemalloc,
> linenoise and lua. Can we unbundle them? And is there some subset of the
> tests we can run?

I'll have a look
Vincent Legoll Dec. 28, 2020, 6:45 p.m. UTC | #3
On Mon, Dec 28, 2020 at 4:47 PM Vincent Legoll <vincent.legoll@gmail.com> wrote:
> > I see there are a number of bundled libraries, included jemalloc,
> > linenoise and lua. Can we unbundle them? And is there some subset of the
> > tests we can run?
>
> I'll have a look

The jemalloc can already be deleted as it is not used (libc malloc is).

The testsuite can be run succesfully minus the 4 ones that I disabled.

Lua is really entangled in the Makefile.

I tried to use guix's linenoise, but wasn't able to make it build.

Hiredis should be updated carefully, so I'll let redis people handle
that.

Updated patchset following...
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d60fdfff17..327834ca73 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2129,14 +2129,14 @@  similar to BerkeleyDB, LevelDB, etc.")
 (define-public redis
   (package
     (name "redis")
-    (version "5.0.7")
+    (version "6.0.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.redis.io/releases/redis-"
                                   version".tar.gz"))
               (sha256
                (base32
-                "0ax8sf3vw0yadr41kzc04917scrg5wir1d94zmbz00b8pzm79nv1"))))
+                "1pc6gyiylrcazlc559dp5mxqj733pk9qabnirw4ry3k23kwdqayw"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f ; tests related to master/slave and replication fail