diff mbox series

[bug#45398,1/2] gnu: Add libinih.

Message ID 20201223171426.9048-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series xfsprogs 5.10.0 & libinih | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Dec. 23, 2020, 5:14 p.m. UTC
* gnu/packages/linux.scm (libinih): New variable.
---
 gnu/packages/linux.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Leo Famulari Dec. 24, 2020, 8:20 p.m. UTC | #1
On Wed, Dec 23, 2020 at 06:14:25PM +0100, Vincent Legoll wrote:
> * gnu/packages/linux.scm (libinih): New variable.

Thanks!

> +    (description "The inih (INI Not Invented Here) library is a simple .INI file
> +parser written in C. It's only a couple of pages of code, and it was designed to
> +be small and simple, so it's good for embedded systems. It's also more or less
> +compatible with Python's ConfigParser style of .INI files, including RFC
> +822-style multi-line syntax and name: value entries.")
> +    (license license:bsd-4)))

I fixed the issues reported by `guix lint`, corrected the license to
bsd-3, and pushed both patches 9325171df468f6a84ac7cdab01f0c6461ff1c7bc
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01f12f77d9..d177f93502 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7000,6 +7000,31 @@  communicate with the kernel.  It can be used to add and remove interfaces, set
 IP addresses and routes, and configure IPsec.")
     (license license:asl2.0)))
 
+(define-public libinih
+  (package
+    (name "libinih")
+    (version "52")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/benhoyt/inih")
+                    (commit (string-append "r" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0lsvm34zabvi1xlximybzvgc58zb90mm3b9babwxlqs05jy871m4"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:configure-flags '("-Ddistro_install=true" "-Ddefault_library=shared")))
+    (home-page "https://github.com/benhoyt/inih")
+    (synopsis "Simple .INI parser library for C")
+    (description "The inih (INI Not Invented Here) library is a simple .INI file
+parser written in C. It's only a couple of pages of code, and it was designed to
+be small and simple, so it's good for embedded systems. It's also more or less
+compatible with Python's ConfigParser style of .INI files, including RFC
+822-style multi-line syntax and name: value entries.")
+    (license license:bsd-4)))
+
 (define-public xfsprogs
   (package
     (name "xfsprogs")