diff mbox series

[bug#45374] gnu: udisks: Add dosfstools to PATH with wrapper.

Message ID 20201222222127.2659-1-dftxbs3e@free.fr
State New
Headers show
Series [bug#45374] gnu: udisks: Add dosfstools to PATH with wrapper. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 22, 2020, 10:21 p.m. UTC
* gnu/packages/freedesktop.scm (udisks):
[inputs]: Add dosfstools.
[arguments]: Modify 'wrap-udisksd phase to add dosfstools in PATH with
wrapper.
---
 gnu/packages/freedesktop.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

dftxbs3e Dec. 22, 2020, 10:44 p.m. UTC | #1
Looks like there has already been some discussion about this: 
https://issues.guix.gnu.org/41247

So what do we do?

Patch libblockdev to use full paths or give it to udisksd's
environment?
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3c4ad57a15..1104a07955 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1112,6 +1112,7 @@  Analysis and Reporting Technology) functionality.")
     (inputs
      `(("acl" ,acl)
        ("cryptsetup" ,cryptsetup)
+       ("dosfstools" ,dosfstools)
        ("libatasmart" ,libatasmart)
        ("libblockdev" ,libblockdev)
        ("libgudev" ,libgudev)
@@ -1163,6 +1164,7 @@  Analysis and Reporting Technology) functionality.")
              (let ((out   (assoc-ref outputs "out"))
                    (utils (assoc-ref inputs "util-linux"))
                    (cryptsetup (assoc-ref inputs "cryptsetup"))
+                   (dosfstools (assoc-ref inputs "dosfstools"))
                    (parted (assoc-ref inputs "parted")))
                (wrap-program (string-append out "/libexec/udisks2/udisksd")
                  `("PATH" ":" prefix
@@ -1170,6 +1172,8 @@  Analysis and Reporting Technology) functionality.")
                     ;; cryptsetup is required for setting encrypted
                     ;; partitions, e.g. in gnome-disks
                     ,(string-append cryptsetup "/sbin")
+                    ;; Required to format FAT file systems in gnome-disks
+                    ,(string-append dosfstools "/sbin")
                     "/run/current-system/profile/bin"
                     "/run/current-system/profile/sbin")))
                #t))))))