diff mbox series

[bug#45309] gnu: font-google-roboto: Unzip fonts to a directory.

Message ID 20201218033431.10787-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#45309] gnu: font-google-roboto: Unzip fonts to a directory. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Dec. 18, 2020, 3:34 a.m. UTC
* gnu/packages/fonts.scm (font-google-roboto)[arguments]: Add phase to unpack
to a directory and ignore macosx files.
---
After commit e93ee2547ecec152f9a198ccc338c4329cc69a71 this pkg doesn't contain anything.
The difference to the version before is that the upstream zip file doesn't
contain a subfolder anymore, so this patch unpacks to one (and excludes macosx
files while at it).

Maybe the roboto-hinted.zip is better than unhinted? Idk.

 gnu/packages/fonts.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Michael Rohleder Dec. 18, 2020, 5:27 a.m. UTC | #1
Now that commit ec4a9cadcb2b44f86917c3ebb17c903149e42883 has reverted
this problem/bug, I'm not sure if the patch is relevant anymore.
Nicolas Goaziou Jan. 12, 2021, 9:12 a.m. UTC | #2
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> After commit e93ee2547ecec152f9a198ccc338c4329cc69a71 this pkg doesn't contain anything.
> The difference to the version before is that the upstream zip file doesn't
> contain a subfolder anymore, so this patch unpacks to one (and excludes macosx
> files while at it).

Oops.

> Maybe the roboto-hinted.zip is better than unhinted? Idk.

There is no roboto-hinted.zip in release v2.138, only
roboto-unhinted.zip and roboto-android.zip. Maybe the latter would be
a better fit?

WDYT?

Regards,
Michael Rohleder Jan. 12, 2021, 9:31 a.m. UTC | #3
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>> Maybe the roboto-hinted.zip is better than unhinted? Idk.
>
> There is no roboto-hinted.zip in release v2.138, only
> roboto-unhinted.zip and roboto-android.zip. Maybe the latter would be
> a better fit?
>
> WDYT?

I don't know, but I guess the android.zip has the same unzipping problem
(haven't looked).

With the patch everything should be good, no?
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 717656d682..72e97d99ea 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -801,6 +801,15 @@  display all Unicode symbols.")
        (sha256
         (base32 "0a57f957qy49kildqx2lp2paqk9i8kkayakmrzxh39hhhmqlrxkh"))))
     (build-system font-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'unpack
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke "unzip" (assoc-ref inputs "source")
+                     "-x" "__MACOSX/*"
+                     "-d" "roboto-unhinted")
+             #t)))))
     (home-page "https://github.com/google/roboto")
     (synopsis "The Roboto family of fonts")
     (description