diff mbox series

[bug#45296] gnu: miredo: Fix to use iproute2 from the store.

Message ID 20201217142418.4497-1-dftxbs3e@free.fr
State Accepted
Headers show
Series [bug#45296] gnu: miredo: Fix to use iproute2 from the store. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 17, 2020, 2:24 p.m. UTC
* gnu/packages/networking.scm (miredo):
[inputs]: Add iproute.
[arguments]: New phase 'patch-iproute2 that patches sources to use
iproute2 from the store.
---
 gnu/packages/networking.scm | 19 ++++++++++++++-----
 1 file changed, 14 insertions(+), 5 deletions(-)

Comments

Efraim Flashner Dec. 26, 2020, 8:31 p.m. UTC | #1
I fixed the patch to not also change the indentation on the other lines
and pushed it. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1226b8606f..281c4a0179 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -688,13 +688,22 @@  or, more generally, MAC addresses of the same category of hardware.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-iproute2
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((iproute (assoc-ref inputs "iproute"))
+                    (ip (string-append iproute "/sbin/ip")))
+               (substitute* "misc/client-hook.iproute"
+                 (("/sbin/ip") ip))
+               #t)))
          ;; The checkconf test in src/ requires network access.
          (add-before
-          'check 'disable-checkconf-test
-          (lambda _
-            (substitute* "src/Makefile"
-              (("^TESTS = .*") "TESTS = \n"))
-            #t)))))
+             'check 'disable-checkconf-test
+           (lambda _
+             (substitute* "src/Makefile"
+               (("^TESTS = .*") "TESTS = \n"))
+             #t)))))
+    (inputs
+     `(("iproute" ,iproute)))
     (home-page "https://www.remlab.net/miredo/")
     (synopsis "Teredo IPv6 tunneling software")
     (description