diff mbox series

[bug#45291] gnu: perl-lwp-protocol-https: Uncomment perl-mozilla-ca input.

Message ID 20201217114619.18199-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#45291] gnu: perl-lwp-protocol-https: Uncomment perl-mozilla-ca input. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines Dec. 17, 2020, 11:46 a.m. UTC
If there's no explicit SSL configuration, the perl-mozilla-ca library acts as
a fallback.  Including this as an input fixes the use of HTTPS in things that
use perl-lwp-protocol-https, for example get-iplayer.

* gnu/packages/web.scm (perl-lwp-protocol-https)[propagated-inputs]: Uncomment
perl-mozilla-ca.
---
 gnu/packages/web.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Efraim Flashner Jan. 3, 2021, 2:20 p.m. UTC | #1
On Thu, Dec 17, 2020 at 11:46:19AM +0000, Christopher Baines wrote:
> If there's no explicit SSL configuration, the perl-mozilla-ca library acts as
> a fallback.  Including this as an input fixes the use of HTTPS in things that
> use perl-lwp-protocol-https, for example get-iplayer.
> 
> * gnu/packages/web.scm (perl-lwp-protocol-https)[propagated-inputs]: Uncomment
> perl-mozilla-ca.
> ---
>  gnu/packages/web.scm | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 39820f7572..b4ebcc8846 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3874,8 +3874,7 @@ exists it is used instead.")
>      (propagated-inputs
>       `(("perl-io-socket-ssl" ,perl-io-socket-ssl)
>         ("perl-libwww" ,perl-libwww)
> -       ;; Users should instead make sure SSL_ca_path is set properly.
> -       ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
> +       ("perl-mozilla-ca" ,perl-mozilla-ca)
>         ("perl-net-http" ,perl-net-http)))
>      (home-page "https://metacpan.org/release/LWP-Protocol-https")
>      (synopsis "HTTPS support for LWP::UserAgent")
> -- 
> 2.29.2

Works for me
Christopher Baines Jan. 3, 2021, 6:22 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> On Thu, Dec 17, 2020 at 11:46:19AM +0000, Christopher Baines wrote:
>> If there's no explicit SSL configuration, the perl-mozilla-ca library acts as
>> a fallback.  Including this as an input fixes the use of HTTPS in things that
>> use perl-lwp-protocol-https, for example get-iplayer.
>> 
>> * gnu/packages/web.scm (perl-lwp-protocol-https)[propagated-inputs]: Uncomment
>> perl-mozilla-ca.
>> ---
>>  gnu/packages/web.scm | 3 +--
>>  1 file changed, 1 insertion(+), 2 deletions(-)
>> 
>> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
>> index 39820f7572..b4ebcc8846 100644
>> --- a/gnu/packages/web.scm
>> +++ b/gnu/packages/web.scm
>> @@ -3874,8 +3874,7 @@ exists it is used instead.")
>>      (propagated-inputs
>>       `(("perl-io-socket-ssl" ,perl-io-socket-ssl)
>>         ("perl-libwww" ,perl-libwww)
>> -       ;; Users should instead make sure SSL_ca_path is set properly.
>> -       ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
>> +       ("perl-mozilla-ca" ,perl-mozilla-ca)
>>         ("perl-net-http" ,perl-net-http)))
>>      (home-page "https://metacpan.org/release/LWP-Protocol-https")
>>      (synopsis "HTTPS support for LWP::UserAgent")
>> -- 
>> 2.29.2
>
> Works for me

Great, pushed as d944f10ddd921a15e6cd17a968ca57f0109a1c36.

Thanks for taking a look!
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 39820f7572..b4ebcc8846 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3874,8 +3874,7 @@  exists it is used instead.")
     (propagated-inputs
      `(("perl-io-socket-ssl" ,perl-io-socket-ssl)
        ("perl-libwww" ,perl-libwww)
-       ;; Users should instead make sure SSL_ca_path is set properly.
-       ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
+       ("perl-mozilla-ca" ,perl-mozilla-ca)
        ("perl-net-http" ,perl-net-http)))
     (home-page "https://metacpan.org/release/LWP-Protocol-https")
     (synopsis "HTTPS support for LWP::UserAgent")