diff mbox series

[bug#45282,1/2] gnu: Add r-kegggraph.

Message ID 20201216220342.3133-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#45282,1/2] gnu: Add r-kegggraph. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Dec. 16, 2020, 10:03 p.m. UTC
* gnu/packages/bioconductor.scm (r-kegggraph): New variable.
---
 gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ricardo Wurmus Dec. 17, 2020, 11:32 a.m. UTC | #1
I applied these with a few changes (moved the packages around and
reordered the commits).

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b4a1af4306..3026d1a496 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9247,3 +9247,29 @@  graph with the mapped data.  In addition, @code{r-pathview} also seamlessly
 integrates with pathway and gene set (enrichment) analysis tools for
 large-scale and fully automated analysis.")
     (license license:gpl3+)))
+
+(define-public r-kegggraph
+  (package
+    (name "r-kegggraph")
+    (version "1.50.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "KEGGgraph" version))
+       (sha256
+        (base32 "1h293hn02ysm923bh9gxk87xv663xiqchqcvpaxpla9c3yrgkx2v"))))
+    (properties `((upstream-name . "KEGGgraph")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-graph" ,r-graph)
+       ("r-rcurl" ,r-rcurl)
+       ("r-xml" ,r-xml)))
+    (home-page "http://www.nextbiomotif.com") ;;no https
+    (synopsis "Graph approach to Kegg Pathway database in R and Bioconductor")
+    (description
+     "@code{r-kegggraph} is an interface between Kegg Pathway database and graph
+object as well as a collection of tools to analyze, dissect and visualize these
+graphs.  It parses the regularly updated kgml (Kegg xml) files into graph models
+maintaining all essential pathway attributes.  The package offers
+functionalities including parsing, graph operation, visualization and etc.")
+    (license license:gpl2+)))