diff mbox series

[bug#45233] gnu: polybar: Update to 3.5.1.

Message ID 20201214085943.3138-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#45233] gnu: polybar: Update to 3.5.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Dec. 14, 2020, 8:59 a.m. UTC
* gnu/packages/wm.scm (polybar): Update to 3.5.1.
[source]: Update URI. [inputs]: Add git.
---
 gnu/packages/wm.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Efraim Flashner Dec. 21, 2020, 8:48 a.m. UTC | #1
(Upcoming) Version 3.5.3 fixes the issue where the documentation
requires using git. Can you re-submit in a couple of days (hopefully!)
when they release a new version?

https://github.com/polybar/polybar/issues/2309

On Mon, Dec 14, 2020 at 09:59:43AM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/wm.scm (polybar): Update to 3.5.1.
> [source]: Update URI. [inputs]: Add git.
> ---
>  gnu/packages/wm.scm | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 6c4f2c6960..4fb80cd827 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -115,6 +115,7 @@
>    #:use-module (gnu packages suckless)
>    #:use-module (gnu packages texinfo)
>    #:use-module (gnu packages textutils)
> +  #:use-module (gnu packages version-control)
>    #:use-module (gnu packages video)
>    #:use-module (gnu packages web)
>    #:use-module (gnu packages xdisorg)
> @@ -1301,14 +1302,14 @@ its size
>  (define-public polybar
>    (package
>      (name "polybar")
> -    (version "3.4.3")
> +    (version "3.5.1")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/polybar/polybar/releases/"
> -                           "download/" version "/polybar-" version ".tar"))
> +                           "download/" version "/polybar-" version ".tar.gz"))
>         (sha256
> -        (base32 "0bw22qvbcdvyd0qv3ax48r34rnclbbb6dyb8h8zljq1r3lf15vfl"))))
> +        (base32 "06d7rprpl9rkbd2nxv0zjq9fhyrzb92843p0c0s5yivssfqzshnk"))))
>      (build-system cmake-build-system)
>      (arguments
>       ;; Test is disabled because it requires downloading googletest from the
> @@ -1317,6 +1318,7 @@ its size
>      (inputs
>       `(("alsa-lib" ,alsa-lib)
>         ("cairo" ,cairo)
> +       ("git" ,git)
>         ("i3-wm" ,i3-wm)
>         ("jsoncpp" ,jsoncpp)
>         ("libmpdclient" ,libmpdclient)
> -- 
> 2.29.2
> 
> 
> 
>
Tanguy LE CARROUR Dec. 23, 2020, 8:13 a.m. UTC | #2
Hi Efraim,


Excerpts from Efraim Flashner's message of décembre 21, 2020 9:48 am:
> (Upcoming) Version 3.5.3 fixes the issue where the documentation
> requires using git. Can you re-submit in a couple of days (hopefully!)
> when they release a new version?
> 
> https://github.com/polybar/polybar/issues/2309

Sorry for not noticing that it was a "bug". I'll do as you said and keep
an eye on the release of 3.5.3!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6c4f2c6960..4fb80cd827 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -115,6 +115,7 @@ 
   #:use-module (gnu packages suckless)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages textutils)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
@@ -1301,14 +1302,14 @@  its size
 (define-public polybar
   (package
     (name "polybar")
-    (version "3.4.3")
+    (version "3.5.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/polybar/polybar/releases/"
-                           "download/" version "/polybar-" version ".tar"))
+                           "download/" version "/polybar-" version ".tar.gz"))
        (sha256
-        (base32 "0bw22qvbcdvyd0qv3ax48r34rnclbbb6dyb8h8zljq1r3lf15vfl"))))
+        (base32 "06d7rprpl9rkbd2nxv0zjq9fhyrzb92843p0c0s5yivssfqzshnk"))))
     (build-system cmake-build-system)
     (arguments
      ;; Test is disabled because it requires downloading googletest from the
@@ -1317,6 +1318,7 @@  its size
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("cairo" ,cairo)
+       ("git" ,git)
        ("i3-wm" ,i3-wm)
        ("jsoncpp" ,jsoncpp)
        ("libmpdclient" ,libmpdclient)