diff mbox series

[bug#45229] gnu: go-github-com-emicklei-go-restful: Update to 3.4.0.

Message ID 20201213230749.31326-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#45229] gnu: go-github-com-emicklei-go-restful: Update to 3.4.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill Dec. 13, 2020, 11:07 p.m. UTC
* gnu/packages/golang.scm (go-github-com-emicklei-go-restful): Update to 3.4.0.
---
 gnu/packages/golang.scm | 44 ++++++++++++++++++++---------------------
 1 file changed, 21 insertions(+), 23 deletions(-)

Comments

Efraim Flashner Dec. 17, 2020, 8:27 p.m. UTC | #1
The package name somehow changed in your patch (from ...-go-restful to
...-go-rest) so I changed it back.

Patch pushed with that change.
Jack Hill Dec. 17, 2020, 8:38 p.m. UTC | #2
On Thu, 17 Dec 2020, Efraim Flashner wrote:

> The package name somehow changed in your patch (from ...-go-restful to
> ...-go-rest) so I changed it back.
>
> Patch pushed with that change.

Whoops! Thanks for catching that and pushing (also for the other go 
package updates).

Best,
Jack
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ae42e24f92..ca2e8c4ff4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1241,31 +1241,29 @@  sockets.")
       (description "Semver is a library for Semantic versioning written in Go.")
       (license license:expat))))
 
-(define-public go-github-com-emicklei-go-restful
-  (let ((commit "89ef8af493ab468a45a42bb0d89a06fccdd2fb22")
-        (revision "0"))
-    (package
-      (name "go-github-com-emicklei-go-restful")
-      (version (git-version "0.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/emicklei/go-restful")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0rrlfcfq80fkxifpih6bq31vavb5mf4530xz51pp9pq1mn2fzjfh"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/emicklei/go-restful"))
-      (home-page "https://github.com/emicklei/go-restful")
-      (synopsis "Build REST-style web services using Go")
-      (description "This package provides @code{go-restful}, which helps
+(define-public go-github-com-emicklei-go-rest
+  (package
+    (name "go-github-com-emicklei-go-restful")
+    (version "3.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emicklei/go-restful")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0m1y5a6xr6hmdj77afrvyh2llkbhn1166lcrgis654shl8zs9qhz"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/emicklei/go-restful"))
+    (home-page "https://github.com/emicklei/go-restful")
+    (synopsis "Build REST-style web services using Go")
+    (description "This package provides @code{go-restful}, which helps
 developers to use @code{http} methods explicitly and in a way that's consistent
 with the HTTP protocol definition.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public go-github-com-google-cadvisor
   (let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")