diff mbox series

[bug#45151] gnu: Add openfortivpn

Message ID 20201212200303.13683-1-mail@davie.li
State Accepted
Headers show
Series [bug#45151] gnu: Add openfortivpn | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

David Dashyan Dec. 12, 2020, 8:03 p.m. UTC
gnu: openfortivpn: adjust inputs and homepage
---
 gnu/packages/vpn.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)


base-commit: 91e35e32a4938e0e37499c64fa8ed3e7cf51dce3

Comments

Leo Famulari Dec. 12, 2020, 9:56 p.m. UTC | #1
On Sat, Dec 12, 2020 at 11:03:03PM +0300, David Dashyan wrote:
> gnu: openfortivpn: adjust inputs and homepage

Thanks! I adjusted the commit message, made sure the description was
composed of complete sentences, and pushed as
18918ebeeb152731e06634a003e8cf3edd24f6a3.
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 04c34c3d4d..90e6778ead 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
+;;; Copyright © 2020 David Dashyan <mail@davie.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -287,6 +288,35 @@  and probably others.")
    (license license:lgpl2.1)
    (home-page "https://www.infradead.org/openconnect/")))
 
+(define-public openfortivpn
+  (package
+    (name "openfortivpn")
+    (version "1.15.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/adrienverge/openfortivpn")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1qsfgpxg553s8rc9cyrc4k96z0pislxsdxb9wyhp8fdprkak2mw2"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("autotools" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("openssl" ,openssl)
+       ("ppp" ,ppp)))
+    (home-page "https://github.com/adrienverge/openfortivpn")
+    (synopsis "Client for PPP+SSL VPN tunnel services")
+    (description
+     "Client for PPP+SSL VPN tunnel services.  It spawns a pppd process and
+operates the communication between the gateway and this process.  It is
+compatible with Fortinet VPNs.")
+    (license license:gpl3+)))
+
 (define-public openvpn
   (package
     (name "openvpn")