diff mbox series

[bug#45188] gnu: Add wlr-randr

Message ID 20201211231129.26373-1-robertsmith@posteo.net
State Accepted
Headers show
Series [bug#45188] gnu: Add wlr-randr | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Robert Smith Dec. 11, 2020, 11:11 p.m. UTC
* gnu/packages/wm.scm (wlr-randr): New variable.
---

This is a utility to manage wayland compositor outputs.

 gnu/packages/wm.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès Dec. 12, 2020, 7:48 p.m. UTC | #1
Hi Robert,

Robert Smith <robertsmith@posteo.net> skribis:

> * gnu/packages/wm.scm (wlr-randr): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3569d7f057..6c4f2c6960 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
+;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1559,6 +1560,27 @@  modules for building a Wayland compositor.")
 Wlroots based compositors.")
     (license license:expat))) ; MIT license
 
+(define-public wlr-randr
+  (package
+    (name "wlr-randr")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emersion/wlr-randr")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "10c8zzp78s5bw34vvjhilipa28bsdx3jbyhnxgp8f8kawh3cvgsc"))))
+    (build-system meson-build-system)
+    (inputs `(("wayland" ,wayland)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/emersion/wlr-randr")
+    (synopsis "Utility to manage Wayland compositor outputs")
+    (description "wlr-randr is a utility to manage outputs of a Wayland compositor.")
+    (license license:expat))) ; MIT license
+
 (define-public mako
   (package
     (name "mako")