diff mbox series

[bug#44990,v2,1/8] gnu: Add python-qtpy.

Message ID 20201211201833.22529-1-dftxbs3e@free.fr
State Accepted
Headers show
Series [bug#44990,v2,1/8] gnu: Add python-qtpy. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 11, 2020, 8:18 p.m. UTC
* gnu/packages/python-xyz.scm (python-qtpy): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Efraim Flashner Dec. 21, 2020, 8:18 a.m. UTC | #1
On Fri, Dec 11, 2020 at 09:18:26PM +0100, John Doe wrote:
> * gnu/packages/python-xyz.scm (python-qtpy): New variable.
> ---
>  gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)

I would put this in gnu/packages/qt actually

> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d312e3172a..a92898c7f0 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -23222,3 +23222,28 @@ process.")
>       "Gamera is a toolkit for building document image recognition systems.")
>      (home-page "https://gamera.informatik.hsnr.de/")
>      (license license:gpl2+)))
> +
> +(define-public python-qtpy
> +  (package
> +    (name "python-qtpy")
> +    (version "1.9.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "QtPy" version))
> +        (sha256
> +          (base32
> +            "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +      `(("python-pyside2" ,python-pyside-2)))
> +    (arguments
> +      `(;; Not all supported bindings are packaged. Especially PyQt4.
> +	#:tests? #f))
> +    (home-page "https://github.com/spyder-ide/qtpy")
> +    (synopsis
> +     "Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets")
> +    (description
> +     "Provides an abstraction layer on top of the various Qt bindings
> +(PyQt5, PyQt4 and PySide) and additional custom QWidgets.")
> +    (license license:expat)))
> -- 
> 2.29.2
> 

I tried a bit to get the tests working. It looks like python-pyside-2
should propagate python-shiboken, and I forgot about
python-pyqtwebengine, which looks like it's necessary to run the tests.
I haven't looked at the other patches yet, but I wonder how useful this
package is with just python-pyside-2 as an input.
dftxbs3e Dec. 27, 2020, 10:26 p.m. UTC | #2
Sorry sending a new revision so fast, missed a mistake.

electrum >=4.0.7 requires python-dnspython >=2

John Doe (8):
  gnu: Add python-qtpy.
  gnu: Add python-helpdev.
  gnu: Add python-qdarkstyle.
  gnu: Add python-bitstring.
  gnu: Add python-socks.
  gnu: python-aiohttp-socks: Update to 0.5.5.
  gnu: libsecp256k1: Update to 20200615-1-dbd41db.
  gnu: electrum: Update to 4.0.9.

 gnu/packages/crypto.scm     | 11 +++--
 gnu/packages/finance.scm    | 29 ++++++-----
 gnu/packages/python-web.scm |  8 +--
 gnu/packages/python-xyz.scm | 98 +++++++++++++++++++++++++++++++++++++
 gnu/packages/qt.scm         | 25 ++++++++++
 5 files changed, 153 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d312e3172a..a92898c7f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23222,3 +23222,28 @@  process.")
      "Gamera is a toolkit for building document image recognition systems.")
     (home-page "https://gamera.informatik.hsnr.de/")
     (license license:gpl2+)))
+
+(define-public python-qtpy
+  (package
+    (name "python-qtpy")
+    (version "1.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "QtPy" version))
+        (sha256
+          (base32
+            "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-pyside2" ,python-pyside-2)))
+    (arguments
+      `(;; Not all supported bindings are packaged. Especially PyQt4.
+	#:tests? #f))
+    (home-page "https://github.com/spyder-ide/qtpy")
+    (synopsis
+     "Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets")
+    (description
+     "Provides an abstraction layer on top of the various Qt bindings
+(PyQt5, PyQt4 and PySide) and additional custom QWidgets.")
+    (license license:expat)))