diff mbox series

[bug#44990,v2,1/8] gnu: Add python-qtpy.

Message ID 20201211200105.21995-1-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#44990,v2,1/8] gnu: Add python-qtpy. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Dec. 11, 2020, 8 p.m. UTC
From: John Doe <dftxbs3e@free.fr>

* gnu/packages/python-xyz.scm (python-qtpy): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d312e3172a..a92898c7f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23222,3 +23222,28 @@  process.")
      "Gamera is a toolkit for building document image recognition systems.")
     (home-page "https://gamera.informatik.hsnr.de/")
     (license license:gpl2+)))
+
+(define-public python-qtpy
+  (package
+    (name "python-qtpy")
+    (version "1.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "QtPy" version))
+        (sha256
+          (base32
+            "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-pyside2" ,python-pyside-2)))
+    (arguments
+      `(;; Not all supported bindings are packaged. Especially PyQt4.
+	#:tests? #f))
+    (home-page "https://github.com/spyder-ide/qtpy")
+    (synopsis
+     "Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets")
+    (description
+     "Provides an abstraction layer on top of the various Qt bindings
+(PyQt5, PyQt4 and PySide) and additional custom QWidgets.")
+    (license license:expat)))