diff mbox series

[bug#44990,v2,4/8] gnu: Add python-bitstring.

Message ID 20201211195331.21451-4-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#44990,v2,1/8] gnu: Add python-qtpy. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Dec. 11, 2020, 7:53 p.m. UTC
From: John Doe <dftxbs3e@free.fr>

* gnu/packages/python-xyz.scm (python-bitstring): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c3591f53b4..4f55ed2e83 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23297,3 +23297,24 @@  environment.")
     (description
       "QDarkStyle is the most complete dark stylesheet for Python and Qt applications.")
     (license license:expat)))
+
+(define-public python-bitstring
+  (package
+    (name "python-bitstring")
+    (version "3.1.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "bitstring" version))
+        (sha256
+          (base32
+            "0jl6192dwrlm5ybkbh7ywmyaymrc3cmz9y07nm7qdli9n9rfpwzx"))))
+    (build-system python-build-system)
+    (home-page
+      "https://github.com/scott-griffiths/bitstring")
+    (synopsis
+      "Simple construction, analysis and modification of binary data")
+    (description
+      "Bitstring is a library for simple construction, analysis and modification
+ of binary data.")
+    (license license:expat)))