diff mbox series

[bug#45132,v2,1/2] gnu: pygame-sdl2-for-renpy: Drop generated sources in snippet.

Message ID 20201210190312.19632-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#45132,v2,1/2] gnu: pygame-sdl2-for-renpy: Drop generated sources in snippet. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Dec. 10, 2020, 7:03 p.m. UTC
* gnu/packages/game-development.scm (pygame-sdl2-for-renpy)[source]<modules>:
Add (guix build utils).
[#:phases]<drop-generated-files>: Move from here...
[source]<snippet>: ... to here.
---
 gnu/packages/game-development.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)

Comments

Nicolas Goaziou Dec. 12, 2020, 8:16 p.m. UTC | #1
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/game-development.scm
> (pygame-sdl2-for-renpy)[source]<modules>:

Both patches applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c57ea5a908..557f02f564 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1071,7 +1071,14 @@  to create fully featured games and multimedia programs in the python language.")
          (method url-fetch)
          (uri (string-append "https://www.renpy.org/dl/" renpy-version
                              "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))))
+         (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             ;; drop generated sources
+             (delete-file-recursively "gen")
+             (delete-file-recursively "gen3")
+             #t))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f                ; tests require pygame to be installed first
@@ -1090,11 +1097,6 @@  to create fully featured games and multimedia programs in the python language.")
                                       "/lib -Wl,-rpath,"
                                       (assoc-ref inputs "sdl-union")
                                       "/lib -Wl,--enable-new-dtags -lSDL2"))
-               #t))
-           (add-before 'build 'drop-generated-files
-             (lambda args
-               (delete-file-recursively "gen")
-               (delete-file-recursively "gen3")
                #t)))))
       (inputs
        `(("sdl-union"