diff mbox series

[bug#45161,1/1] gnu: Update go

Message ID 20201210151755.25621-1-mail@davie.li
State Accepted
Headers show
Series Update go? | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

David Dashyan Dec. 10, 2020, 3:17 p.m. UTC
---
 gnu/packages/golang.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Leo Famulari Dec. 10, 2020, 5:43 p.m. UTC | #1
On Thu, Dec 10, 2020 at 06:17:55PM +0300, David Dashyan wrote:
> -(define-public go-1.14
> +(define-public go-1.15
>    (package
>      (inherit go-1.4)
>      (name "go")
> -    (version "1.14.10")
> +    (version "1.15.6")

Thanks! I'm doing some tests now. As Jack said, we'll need to update the
'go' package as well in order for this to take effect.

Depending on whether or not the Go packages work with 1.15, we might
need to keep 1.14 around for a while.

For example, check out a Git worktree at commit
18199da4b79ce79d5002c3290cc1fa95454d92ce (gnu: Add Go 1.12.)

In that commit, we added 1.12 but kept 1.11 as the default Go compiler.

$ git worktree add /tmp/guix-multiple-go-compilers 18199da4b79ce79d5002c3290cc1fa95454d92ce && cd /tmp/guix-multiple-go-compilers
David Dashyan Dec. 13, 2020, 9:31 p.m. UTC | #2
Hello Jack and Leo!

Thank you for review and for picking it up :)

As suggested senditng the patch adding go-1.15 but keeping go-1.14.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b42bf3c8f..e367eb4d16 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 David Dashyan <mail@davie.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -230,11 +231,11 @@  in the style of communicating sequential processes (@dfn{CSP}).")
     (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux"))
     (license license:bsd-3)))
 
-(define-public go-1.14
+(define-public go-1.15
   (package
     (inherit go-1.4)
     (name "go")
-    (version "1.14.10")
+    (version "1.15.6")
     (source
      (origin
        (method git-fetch)
@@ -244,7 +245,7 @@  in the style of communicating sequential processes (@dfn{CSP}).")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0h1nmqzjc0xxpn6n2hjq7692gdqkznagzdmiq9490yzkrrii2lgk"))))
+         "0pg811lfw1pdp0cba4jvsqbwjaqrqz6m7jspbc80r17snd7flk2z"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.4)
        ((#:system system)
@@ -277,7 +278,8 @@  in the style of communicating sequential processes (@dfn{CSP}).")
                  ;; not find object files/headers despite being present.
                  (for-each
                   delete-file
-                  '("cmd/go/testdata/script/mod_case_cgo.txt"
+                  '("cmd/go/testdata/script/ldflag.txt"
+                    "cmd/go/testdata/script/mod_case_cgo.txt"
                     "cmd/go/testdata/script/list_find.txt"
                     "cmd/go/testdata/script/list_compiled_imports.txt"
                     "cmd/go/testdata/script/cgo_syso_issue29253.txt"