diff mbox series

[bug#45112] gnu: maven-wagon-http: Disable a failing test.

Message ID 20201208034711.21554-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#45112] gnu: maven-wagon-http: Disable a failing test. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Dec. 8, 2020, 3:47 a.m. UTC
* gnu/packages/maven.scm (maven-wagon-http)[arguments]: Add
HugeFileDownloadTest to excluded tests.
---
 gnu/packages/maven.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Julien Lepiller Dec. 8, 2020, 12:08 p.m. UTC | #1
The test passes here, though after a long time… What kind of system are you using? Do you really get a timeout, or are you simply impatient? :)

Le 7 décembre 2020 22:47:11 GMT-05:00, Michael Rohleder <mike@rohleder.de> a écrit :
>* gnu/packages/maven.scm (maven-wagon-http)[arguments]: Add
>HugeFileDownloadTest to excluded tests.
>---
> gnu/packages/maven.scm | 2 ++
> 1 file changed, 2 insertions(+)
>
>diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
>index ad14c1aa62..c637e5c7ae 100644
>--- a/gnu/packages/maven.scm
>+++ b/gnu/packages/maven.scm
>@@ -889,6 +889,8 @@ wagon providers supporting HTTP.")))
>         ;; unable to find valid certification path to requested target
>                         "**/HttpsWagonPreemptiveTest.java"
>                         "**/HttpsWagonTest.java"
>+                        ;; Timeout
>+                        "**/HugeFileDownloadTest.java"
>                         ;; Injection errors
>                         "**/TckTest.java")
>        #:jdk ,icedtea-8
>-- 
>2.29.2
Michael Rohleder Dec. 8, 2020, 3:45 p.m. UTC | #2
Julien Lepiller <julien@lepiller.eu> writes:
> The test passes here, though after a long time… What kind of system
> are you using? Do you really get a timeout, or are you simply
> impatient? :)

Yes, I really get a (reproducable) timeout:
And yes, in some situations I can be impatient.  But not on building
software.  Computers are too slow anyway. ;)

Hardware:
Intel i7-4930K @ 3.9GHz, 32GB Ram, SSD
Julien Lepiller Dec. 15, 2020, 2:39 p.m. UTC | #3
Le Tue, 08 Dec 2020 16:45:00 +0100,
Michael Rohleder <mike@rohleder.de> a écrit :

> Julien Lepiller <julien@lepiller.eu> writes:
> > The test passes here, though after a long time… What kind of system
> > are you using? Do you really get a timeout, or are you simply
> > impatient? :)  
> 
> Yes, I really get a (reproducable) timeout:

Pushed as 1962c6b286e36b8d5165a4992710f3132adb04c4.

Thank you, and sorry for the delay!
diff mbox series

Patch

diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index ad14c1aa62..c637e5c7ae 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -889,6 +889,8 @@  wagon providers supporting HTTP.")))
                         ;; unable to find valid certification path to requested target
                         "**/HttpsWagonPreemptiveTest.java"
                         "**/HttpsWagonTest.java"
+                        ;; Timeout
+                        "**/HugeFileDownloadTest.java"
                         ;; Injection errors
                         "**/TckTest.java")
        #:jdk ,icedtea-8