diff mbox series

[bug#45100] gnu: emacs-modus-themes: Update to 1.0.2.

Message ID 20201207124322.7570-1-andremegafone@gmail.com
State Accepted
Headers show
Series [bug#45100] gnu: emacs-modus-themes: Update to 1.0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

André A. Gomes Dec. 7, 2020, 12:43 p.m. UTC
Deprecates emacs-modus-operandi/vivendi-theme.
---
 gnu/packages/emacs-xyz.scm | 60 +++++++++-----------------------------
 1 file changed, 13 insertions(+), 47 deletions(-)

Comments

Nicolas Goaziou Dec. 7, 2020, 3:32 p.m. UTC | #1
Hello,

André Alexandre Gomes <andremegafone@gmail.com> writes:

> Deprecates emacs-modus-operandi/vivendi-theme.

Thank you! I applied your patch with the following changes:

- I wrote a complete commit message,

- I fixed the order of packages (you cannot deprecate a package before
  the definition of the new package)

- I relocated the home-page to https://protesilaos.com/modus-themes/

- I expounded the description (in particular, it consists of full
  sentences now).

I'm now waiting for GNU ELPA to catch up so we can switch back to this
source.

Regards,
André A. Gomes Dec. 9, 2020, 9:24 a.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Thank you! I applied your patch with the following changes:
>
> - I wrote a complete commit message,
>
> - I fixed the order of packages (you cannot deprecate a package before
>   the definition of the new package)
>
> - I relocated the home-page to https://protesilaos.com/modus-themes/
>
> - I expounded the description (in particular, it consists of full
>   sentences now).

Thank you Nicolas.  I will keep in mind these observations in future
patches.

> I'm now waiting for GNU ELPA to catch up so we can switch back to this
> source.

Right, I recall you mentioning that we should stick to GNU ELPA since
it's easier to maintain.  Let's keep in mind that the themes will be
part of Emacs in the next release.  At that point, Guix doesn't need to
package it anymore.

--
André Alexandre Gomes
"Free Thought, Free World"
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7fd8f3c245..adf08f14c6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -86,6 +86,7 @@ 
 ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
 ;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 André A. Gomes <andremegafone@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23225,68 +23226,33 @@  Emacs that integrate with major modes like Org-mode.")
       (license license:expat))))
 
 (define-public emacs-modus-operandi-theme
-  (package
-    (name "emacs-modus-operandi-theme")
-    (version "0.13.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://gitlab.com/protesilaos/modus-themes")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-other-theme
-           (lambda _
-             (delete-file "modus-vivendi-theme.el")
-             #t)))))
-    (home-page "https://gitlab.com/protesilaos/modus-themes")
-    (synopsis "Accessible light theme (WCAG AAA)")
-    (description
-     "Modus operandi is the light version of the Modus accessible themes for
-GNU Emacs.  The contrast ratio between foreground and background values should
-always be greater than 7:1, which conforms with the WCAG AAA accessibility
-standard.  This is the highest standard of its kind.")
-    (license license:gpl3+)))
+  (deprecated-package "emacs-modus-operandi-theme" emacs-modus-themes))
 
 (define-public emacs-modus-vivendi-theme
+  (deprecated-package "emacs-modus-vivendi-theme" emacs-modus-themes))
+
+(define-public emacs-modus-themes
   (package
-    (name "emacs-modus-vivendi-theme")
-    (version "0.13.0")
+    (name "emacs-modus-themes")
+    (version "1.0.2")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://gitlab.com/protesilaos/modus-themes")
+             (url "https://gitlab.com/protesilaos/modus-themes.git")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
+        (base32 "1v82payjgx8z0qdklsrkim7xkb6hqrbs34d5qpq0sii43jwhiy5j"))))
     (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-other-theme
-           (lambda _
-             (delete-file "modus-operandi-theme.el")
-             #t)))))
     (home-page "https://gitlab.com/protesilaos/modus-themes")
-    (synopsis "Accessible dark theme (WCAG AAA)")
+    (synopsis "Accessible themes (WCAG AAA)")
     (description
-     "Modus vivendi is the dark version of the Modus accessible themes for GNU
-Emacs.  The contrast ratio between foreground and background values should
-always be greater than 7:1, which conforms with the WCAG AAA accessibility
-standard.  This is the highest standard of its kind.")
+     "Highly accessible themes for GNU Emacs, conforming with the highest
+standard for colour contrast between background and foreground values (WCAG
+AAA).")
     (license license:gpl3+)))
 
-(define-public emacs-modus-themes
-  (deprecated-package "emacs-modus-themes" emacs-modus-operandi-theme))
-
 (define-public emacs-punpun-theme
   (let ((commit "2f78125609277b2478abdebd8f9d5ee10a823b65")
         (revision "0"))