diff mbox series

[bug#45096] gnu: python-arrow: Update to 0.17.0.

Message ID 20201207100920.6899-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#45096] gnu: python-arrow: Update to 0.17.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Dec. 7, 2020, 10:09 a.m. UTC
* gnu/packages/time.scm (python-arrow): Update to 0.17.0.
[arguments]: Replace check phase to invoke pytest.
[native-inputs]: Add python-pytest, python-pytest-cov and
python-pytest-mock.
[propagated-inputs]: Add python-pytz.
[home-page]: Update.
---
 gnu/packages/time.scm | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Dec. 13, 2020, 7:51 a.m. UTC | #1
I added a copyright line for you and pushed. Thanks!
Tanguy LE CARROUR Dec. 13, 2020, 2:10 p.m. UTC | #2
Excerpts from Efraim Flashner's message of December 13, 2020 8:51 am:
> I added a copyright line for you and pushed. Thanks!

Sorry for the omission!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index d9ea0e12c2..e10258b6db 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -399,21 +399,30 @@  timestamps.")
 (define-public python-arrow
   (package
     (name "python-arrow")
-    (version "0.10.0")
+    (version "0.17.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "arrow" version))
               (sha256
                (base32
-                "08n7q2l69hlainds1byd4lxhwrq7zsw7s640zkqc3bs5jkq0cnc0"))))
+                "1m3fpz96w3g08i9x9cpqh3cr795y9zbj1bfnay3ccdhxv86d227z"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "pytest" "-vv" "tests"))))))
     (native-inputs
      `(;; For testing
        ("python-chai" ,python-chai)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-mock" ,python-pytest-mock)
        ("python-simplejson" ,python-simplejson)))
     (propagated-inputs
-     `(("python-dateutil" ,python-dateutil)))
-    (home-page "https://github.com/crsmithdev/arrow/")
+     `(("python-dateutil" ,python-dateutil)
+       ("python-pytz" ,python-pytz)))
+    (home-page "https://github.com/arrow-py/arrow")
     (synopsis "Dates and times for Python")
     (description
      "Arrow is a Python library to creating, manipulating, formatting and