diff mbox series

[bug#45043] gnu: git-open: Remove unnecessary propagated input.

Message ID 20201204205332.28505-1-eu@euandre.org
State Accepted
Headers show
Series [bug#45043] gnu: git-open: Remove unnecessary propagated input. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

EuAndreh Dec. 4, 2020, 8:53 p.m. UTC
* gnu/packages/version-control.scm (git-open): Stop propagating xdg-utils
package, and replace the runtime dependency by wrapping xdg-utils in the
derivation.  Also use copy-build-system instead of trivial-build-system.
---
 gnu/packages/version-control.scm | 25 +++++++++++++------------
 1 file changed, 13 insertions(+), 12 deletions(-)

Comments

Leo Famulari Dec. 5, 2020, 4:42 a.m. UTC | #1
On Fri, Dec 04, 2020 at 05:53:32PM -0300, EuAndreh via Guix-patches via wrote:
> * gnu/packages/version-control.scm (git-open): Stop propagating xdg-utils
> package, and replace the runtime dependency by wrapping xdg-utils in the
> derivation.  Also use copy-build-system instead of trivial-build-system.

Thanks! I rewrote the commit to be more idiomatic and pushed as
4cf3734c56d669ee2d78082e5d7c4d0a58e0f800.

About the commit message, we write them in the GNU ChangeLog format:

https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

Basically, we describe changes to the code, organized by file and
variable. The linked chapter in the GNU coding manual is instructive
when combined with `git log` of the Guix repo.
EuAndreh Dec. 5, 2020, 11:19 a.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> Thanks! I rewrote the commit to be more idiomatic and pushed as
> 4cf3734c56d669ee2d78082e5d7c4d0a58e0f800.
>
> About the commit message, we write them in the GNU ChangeLog format:
>
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html
>
> Basically, we describe changes to the code, organized by file and
> variable. The linked chapter in the GNU coding manual is instructive
> when combined with `git log` of the Guix repo.

Hmm, makes sense. Thanks for the tip. I see my commit message was only
partially compliant.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a8e6d2c4b9..eec57b3b6d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -55,6 +55,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix hg-download)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system perl)
@@ -2733,20 +2734,20 @@  file contents on a remote server.")
        (file-name (git-file-name name version))
        (sha256
         (base32 "11n46bngvca5wbdbfcxzjhjbfdbad7sgf7h9gf956cb1q8swsdm0"))))
-    (build-system trivial-build-system)
-    (propagated-inputs
+    (build-system copy-build-system)
+    (inputs
      `(("xdg-utils" ,xdg-utils)))
     (arguments
-     `(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let ((source (assoc-ref %build-inputs "source"))
-               (out    (assoc-ref %outputs "out")))
-           (mkdir-p (string-append out "/bin"))
-           (copy-file (string-append source "/git-open")
-                      (string-append out "/bin/git-open"))
-           #t))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-program
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (xdg-utils (assoc-ref inputs "xdg-utils")))
+               (wrap-program (string-append out "/bin/git-open")
+                 `("PATH" ":" prefix (,(string-append xdg-utils "/bin"))))))))
+       #:install-plan
+       '(("git-open" "bin/git-open"))))
     (home-page "https://github.com/paulirish/git-open")
     (synopsis "Open a Git repository's homepage from the command-line")
     (description