diff mbox series

[bug#44987,2/7] gnu: Add python-qdarkstyle.

Message ID 20201201112530.262013-2-dftxbs3e@free.fr
State Accepted
Headers show
Series [bug#44987,1/7] gnu: Add python-helpdev. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 1, 2020, 11:25 a.m. UTC
From: John Doe <dftxbs3e@free.fr>

* gnu/packages/python-xyz.scm (python-qdarkstyle): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36373ae71c..758496d52f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23278,3 +23278,30 @@  process.")
     (description
       "HelpDev - Extracts information about the Python environment easily.")
     (license license:expat)))
+
+(define-public python-qdarkstyle
+  (package
+    (name "python-qdarkstyle")
+    (version "2.8.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "QDarkStyle" version))
+        (sha256
+          (base32
+            "0883vzg35fzpyl1aiijzpfcdfvpq5vi325w0m7xkx7nxplh02fym"))))
+    (build-system python-build-system)
+    (arguments
+      `(;; Fails unable to detect valid Qt bindings even if you
+	;; add them as native-inputs.
+	#:tests? #f))
+    (propagated-inputs
+      `(("python-helpdev" ,python-helpdev)
+        ("python-qtpy" ,python-qtpy)))
+    (home-page
+      "https://github.com/ColinDuquesnoy/QDarkStyleSheet")
+    (synopsis
+      "The most complete dark stylesheet for Python and Qt applications")
+    (description
+      "The most complete dark stylesheet for Python and Qt applications")
+    (license license:expat)))