diff mbox series

[bug#43976] Chicken build system + some example eggs

Message ID 20201201051428.15ac4d84@riseup.net
State Accepted
Headers show
Series [bug#43976] Chicken build system + some example eggs | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Dec. 1, 2020, 4:14 a.m. UTC
On Fri, 27 Nov 2020 10:09:29 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> Hi raingloom!
> 
> raingloom <raingloom@riseup.net> skribis:
> 
> > From 2ba52705cf909590a428ea598dfdf1c61ada6a8c Mon Sep 17 00:00:00
> > 2001 From: raingloom <raingloom@riseup.net>
> > Date: Mon, 12 Oct 2020 04:11:59 +0200
> > Subject: [PATCH 01/20] gnu: Added search paths for Chicken Scheme.
> >
> > * gnu/packages/chicken.scm (chicken): Added search paths
> >   [native-search-paths]: added CHICKEN_REPOSITORY_PATH and a
> > comment about CHICKEN_INCLUDE_PATH.  
> 
> [...]
> 
> > +    (native-search-paths
> > +     (list (search-path-specification
> > +            (variable "CHICKEN_REPOSITORY_PATH")
> > +            ;; TODO extract binary version into a module level
> > definition.
> > +            (files (list "var/lib/chicken/11")))))
> > +    ;; the use of this variable is unclear. the online docs don't
> > even
> > +    ;; mention it. i'm leaving it in as a comment for now, in case
> > +    ;; something breaks.
> > +    ;; (search-path-specification
> > +    ;;  (variable "CHICKEN_INCLUDE_PATH")
> > +    ;;  (files '("share")))  
> 
> I think you can remove the comment here; presumably we now know that
> CHICKEN_REPOSITORY_PATH is the one that matters.  :-)

I guess I can, since it doesn't looks like it will cause problems. I
left leave the commented path there though.

> Could you please ensure that earlier comments notably at
> <https://issues.guix.gnu.org/43976#1> have been taken into account,
> that the SRFI packages still build and have a layout consistent with
> the var/lib/chicken/11 search path above, and send a v2 of the whole
> series?
> 
> Thanks in advance!
> 
> Ludo’.

Everything builds, tests succeed, and the layouts are the same.
The comments have been taken into account. I listed them in previous
mails so I'll skip them now.
For srfi-14, I hope "non-copyleft" is fine.
Ran guix lint on all packages and it only mentioned archival.

Thanks for the feedback!

ps.: sending the updated original patchset.
i also have these for a later patchset:
0011-gnu-Added-chicken-compile-file.patch
0012-gnu-Added-chicken-srfi-18.patch
0013-gnu-Added-chicken-srfi-13.patch
0014-Added-chicken-check-errors.patch
0015-Added-chicken-defstruct.patch
0016-gnu-Added-chicken-matchable.patch
0017-gnu-Added-chicken-record-variants.patch
0018-gnu-Added-chicken-srfi-41.patch
0019-gnu-Added-chicken-uri-common.patch
0020-gnu-Added-chicken-uri-generic.patch

Comments

Ludovic Courtès Dec. 3, 2020, 4:04 p.m. UTC | #1
Hi raingloom,

I’ve now pushed the 11 patches as of
b5a6eddd8e9f2e840f47d3307f436433e74e16f3, tweaking packages in minor
ways: tweaking descriptions (info "(guix) Synopses and Descriptions"),
adding a ‘file-name’ field in origin that contains the full package name
and version, changing ‘native-inputs’ to ‘inputs’ in a couple of cases,
removing the stale search path comment as discussed earlier, adjusting
commit logs.

Thanks!

Ludo’.
diff mbox series

Patch

From 869b56d5eba824024a50d9de28d2265955526146 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Tue, 13 Oct 2020 09:54:39 +0200
Subject: [PATCH 10/20] gnu: Added chicken-agrep.

* gnu/packages/chicken.scm (chicken-agrep): New variable.
---
 gnu/packages/chicken.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 4f442a51d9..b700b21d29 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -165,6 +165,38 @@  a characters and be compared to other character sets")
 and binary search.")
     (license license:bsd-3)))
 
+(define-public chicken-agrep
+  (package
+    (name "chicken-agrep")
+    (version "1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/iraikov/chicken-agrep")
+             (commit version)))
+       (file-name "agrep")
+       (sha256
+        (base32
+         "0z05x7f154n9bgmainrsmncf5i6dil43r9ymr3rdgwbg4wnxmz4s"))))
+    ;; TODO do we really have to make these propagated?
+    ;; I don't know Chicken's module system well enough to tell
+    (propagated-inputs
+     `(("chicken-datatype" ,chicken-datatype)
+       ("chicken-srfi-1" ,chicken-srfi-1)
+       ("chicken-srfi-14" ,chicken-srfi-14)))
+    (native-inputs
+     `(("chicken-test" ,chicken-test)))
+    (build-system chicken-build-system)
+    (arguments '(#:egg-name "agrep"))
+    (synopsis "Approximate string matching library")
+    (home-page "https://wiki.call-cc.org/eggref/5/agrep")
+    (description
+     "This library implements the Wu-Manber algorithm for approximate string
+searching with errors, popularized by the agrep Unix command and the glimpse
+file indexing tool.")
+    (license license:gpl3+)))
+
 (define-public chicken-datatype
   (package
     (name "chicken-datatype")
-- 
2.29.2