diff mbox series

[bug#44978] gnu: Add cjson.

Message ID 20201201041027.6129-1-rprior@protonmail.com
State Accepted
Headers show
Series [bug#44978] gnu: Add cjson. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Prior Dec. 1, 2020, 4:10 a.m. UTC
* gnu/packages/web.scm (cjson): New variable.
---
 gnu/packages/web.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Christopher Baines Dec. 8, 2020, 9:41 a.m. UTC | #1
Hey, I pushed this to master as
ab58b2cc32068fc9e5f0a7c7ae112349943b7dfd.

The only thing I changed here is I moved the package in to the
javascript module, as that seemed more appropriate than the web module.

Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/web.scm (cjson): New variable.
> ---
>  gnu/packages/web.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index f559d63f1b..21fc1ae964 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -957,6 +957,26 @@ project)
>  @end itemize")
>      (license license:bsd-2)))
>  
> +(define-public cjson
> +  (package
> +    (name "cjson")
> +    (version "1.7.14")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/DaveGamble/cJSON")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "1rlnailhjm180zb6pc17jwphjwivw8kfpqgixjfgq4iyryq46sah"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:configure-flags '("-DENABLE_CJSON_UTILS=On")))
> +    (home-page "https://github.com/DaveGamble/cJSON")
> +    (synopsis "JSON parser written in ANSI C")
> +    (description "This library provides a portable embeddable JSON parser.")
> +    (license license:expat)))
> +
>  (define-public qjson
>    (package
>      (name "qjson")
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f559d63f1b..21fc1ae964 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -957,6 +957,26 @@  project)
 @end itemize")
     (license license:bsd-2)))
 
+(define-public cjson
+  (package
+    (name "cjson")
+    (version "1.7.14")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/DaveGamble/cJSON")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1rlnailhjm180zb6pc17jwphjwivw8kfpqgixjfgq4iyryq46sah"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags '("-DENABLE_CJSON_UTILS=On")))
+    (home-page "https://github.com/DaveGamble/cJSON")
+    (synopsis "JSON parser written in ANSI C")
+    (description "This library provides a portable embeddable JSON parser.")
+    (license license:expat)))
+
 (define-public qjson
   (package
     (name "qjson")