diff mbox series

[bug#44958,1/2] gnu: Add python-pytaglib.

Message ID 20201130105047.8755-1-mjbecze@riseup.net
State Accepted
Headers show
Series Update Nicotine to 2.1.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze Nov. 30, 2020, 10:50 a.m. UTC
* gnu/packages/mp3.scm (python-pytaglib): New variable.
---
 gnu/packages/mp3.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Leo Famulari Nov. 30, 2020, 5:24 p.m. UTC | #1
On Mon, Nov 30, 2020 at 04:50:46AM -0600, Martin Becze wrote:
> * gnu/packages/mp3.scm (python-pytaglib): New variable.

> +    (license license:gpl3+)))

Also, I changed this to 'gpl3'. The source file license headers do not
mention any later versions of the license.
Martin Becze Nov. 30, 2020, 5:29 p.m. UTC | #2
Thank you for reviewing this Leo.

On 11/30/20 11:24 AM, Leo Famulari wrote:
> On Mon, Nov 30, 2020 at 04:50:46AM -0600, Martin Becze wrote:
>> * gnu/packages/mp3.scm (python-pytaglib): New variable.
> 
>> +    (license license:gpl3+)))
> 
> Also, I changed this to 'gpl3'. The source file license headers do not
> mention any later versions of the license.
> 
Ok cool! I didn't realize there was a difference.
Leo Famulari Nov. 30, 2020, 5:35 p.m. UTC | #3
On Mon, Nov 30, 2020 at 11:29:56AM -0600, Martin Becze wrote:
> On 11/30/20 11:24 AM, Leo Famulari wrote:
> > Also, I changed this to 'gpl3'. The source file license headers do not
> > mention any later versions of the license.
> > 
> Ok cool! I didn't realize there was a difference.

Here's an example of what it looks like when the "or later" clause is
present:

https://github.com/moddevices/caps-lv2/blob/master/Amp.cc#L15

Basically, it means the copyright holder agrees in advance to use any
version of the GPL that the Free Software Foundation may invent in the
future.
diff mbox series

Patch

diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index ac546e8c95..2a7242dc42 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -591,3 +591,28 @@  FFmpeg, etc.")
      "This package provides bindings for the Chromaprint acoustic
 fingerprinting library and the Acoustid API.")
     (license license:expat)))
+
+(define-public python-pytaglib
+  (package
+    (name "python-pytaglib")
+    (version "1.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytaglib" version))
+       (sha256
+        (base32
+         "0li970qslfymz4vk1wrij2nfqw3l15cpc3fjjci48mpvg17gbnhn"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("taglib" ,taglib)
+       ("python-pytest" ,python-pytest)))
+    (home-page
+     "http://github.com/supermihi/pytaglib")
+    (synopsis
+     "Python binding for taglib")
+    (description
+     "This package is a Python audio tagging library.  It is
+cross-platform, works with all Python versions, and is very
+simple to use yet fully feature.")
+    (license license:gpl3+)))