diff mbox series

[bug#44077,v5,7/7] gnu: poetry: Update to 1.1.4.

Message ID 20201130094903.11700-7-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#44077,v5,1/7] gnu: python-packaging: Update to 20.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Nov. 30, 2020, 9:49 a.m. UTC
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.
[arguments]: Loosen constraint on python-keyring only.
[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.
Add python-pip, python-packaging and python-poetry-core.
Use python-requests-toolbelt-0.9.1.
---
 gnu/packages/python-xyz.scm | 23 +++++++++--------------
 1 file changed, 9 insertions(+), 14 deletions(-)

Comments

Nicolas Goaziou Nov. 30, 2020, 9:42 p.m. UTC | #1
Hello,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.

I applied the patches. Thank you.

Regards,
Tanguy LE CARROUR Dec. 1, 2020, 7:03 a.m. UTC | #2
Excerpts from Nicolas Goaziou's message of November 30, 2020 10:42 pm:
> Hello,
> 
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> 
>> * gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.
> 
> I applied the patches. Thank you.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6580d22994..1086d724f1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13208,7 +13208,7 @@  compatible build front-ends to build Poetry managed projects.")
 (define-public poetry
   (package
     (name "poetry")
-    (version "1.0.10")
+    (version "1.1.4")
     ;; Poetry can only be built from source with Poetry.
     (source
      (origin
@@ -13216,7 +13216,7 @@  compatible build front-ends to build Poetry managed projects.")
        (uri (pypi-uri "poetry" version))
        (sha256
         (base32
-         "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))
+         "1a2kgfiw66fvxhlqk5qc83s6l38czfh5hcsrbiy7qq5yfc8mlsll"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ;; Pypi does not have tests.
@@ -13225,14 +13225,9 @@  compatible build front-ends to build Poetry managed projects.")
          (add-before 'build 'patch-setup-py
            (lambda _
              (substitute* "setup.py"
-               ;; poetry won't update version as 21.0.0 relies on python > 3.6
-               (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
-               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
-               ;; Reported upstream:
-               ;; <https://github.com/python-poetry/poetry/issues/2752>.
-               (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
-               (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")
-               (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))
+               ;; Newer versions of keyring produce a package with version "0.0.0"
+               ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>
+               (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0"))
              #t)))))
     (propagated-inputs
      `(("python-cachecontrol" ,python-cachecontrol)
@@ -13240,15 +13235,15 @@  compatible build front-ends to build Poetry managed projects.")
        ("python-cleo" ,python-cleo)
        ("python-clikit" ,python-clikit)
        ("python-html5lib" ,python-html5lib)
-       ("python-jsonschema" ,python-jsonschema)
        ("python-keyring" ,python-keyring)
        ("python-msgpack-transitional" ,python-msgpack-transitional)
+       ("python-packaging" ,python-packaging)
        ("python-pexpect" ,python-pexpect)
+       ("python-pip" ,python-pip)
        ("python-pkginfo" ,python-pkginfo)
-       ("python-pyparsing" ,python-pyparsing)
-       ("python-pyrsistent" ,python-pyrsistent)
+       ("python-poetry-core" ,python-poetry-core)
        ("python-requests" ,python-requests)
-       ("python-requests-toolbelt" ,python-requests-toolbelt)
+       ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1)
        ("python-shellingham" ,python-shellingham)
        ("python-tomlkit" ,python-tomlkit)
        ("python-virtualenv" ,python-virtualenv)))