diff mbox series

[bug#44954,08/12] gnu: Add ghc-wai-handler-launch.

Message ID 20201129223301.19210-8-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#44954,01/12] gnu: ghc-doctest: Update to 0.16.3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Nov. 29, 2020, 10:32 p.m. UTC
* gnu/packages/haskell-web.scm (ghc-wai-handler-launch): New variable.
---
 gnu/packages/haskell-web.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 12cd8a2a0d..ae923dc6f1 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2213,3 +2213,34 @@  changing the semantics.")
     "This package provides static file serving
 subsite for Yesod Web Framework.")
    (license license:expat)))
+
+(define-public ghc-wai-handler-launch
+  (package
+   (name "ghc-wai-handler-launch")
+   (version "3.0.3.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://hackage.haskell.org/package/wai-handler-launch/wai-handler-launch-"
+           version
+           ".tar.gz"))
+     (sha256
+      (base32
+       "1ifqgyc1ccig5angh5l1iq7vyms4lvi8wzvysg5dw82nml49n02m"))))
+   (build-system haskell-build-system)
+   (inputs
+    `(("ghc-wai" ,ghc-wai)
+      ("ghc-warp" ,ghc-warp)
+      ("ghc-http-types" ,ghc-http-types)
+      ("ghc-streaming-commons" ,ghc-streaming-commons)
+      ("ghc-async" ,ghc-async)))
+   (home-page
+    "http://hackage.haskell.org/package/wai-handler-launch")
+   (synopsis
+    "Launch a web app in the default browser")
+   (description
+    "This package  handles cross-platform launching and inserts
+Javascript code to ping the server.  When the server no longer
+receives pings, it shuts down.")
+   (license license:expat)))