diff mbox series

[bug#44954,06/12] gnu: Add ghc-hjsmin.

Message ID 20201129223301.19210-6-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#44954,01/12] gnu: ghc-doctest: Update to 0.16.3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Nov. 29, 2020, 10:32 p.m. UTC
* gnu/packages/haskell-web.scm (ghc-hjsmin): New variable.
---
 gnu/packages/haskell-web.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 424a734900..e00afbaf8c 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2129,3 +2129,35 @@  using CSS selectors.")
     "This package provides a WAI application for static serving
 provides some helper functions and datatypes for use outside of WAI.")
    (license license:expat)))
+
+(define-public ghc-hjsmin
+  (package
+   (name "ghc-hjsmin")
+   (version "0.2.0.4")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://hackage.haskell.org/package/hjsmin/hjsmin-"
+           version
+           ".tar.gz"))
+     (sha256
+      (base32
+       "1r2p5rjdjr25j3w4s57q5hxw2c3ymw12x7ms18yvglnq2ivr9fc1"))))
+   (build-system haskell-build-system)
+   (arguments
+    `(#:tests? #f))                     ;there are none
+   (inputs
+    `(("ghc-language-javascript"
+       ,ghc-language-javascript)
+      ("ghc-optparse-applicative"
+       ,ghc-optparse-applicative)))
+   (native-inputs `(("ghc-extra" ,ghc-extra)))
+   (home-page "https://github.com/erikd/hjsmin")
+   (synopsis
+    "Haskell implementation of a javascript minifier")
+   (description
+    "This package reduces size of javascript files by stripping
+out extraneous whitespace and other syntactic elements, without
+changing the semantics.")
+   (license license:bsd-3)))