diff mbox series

[bug#44954,05/12] gnu: Add ghc-cryptonite-conduit.

Message ID 20201129223301.19210-5-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#44954,01/12] gnu: ghc-doctest: Update to 0.16.3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Nov. 29, 2020, 10:32 p.m. UTC
* gnu/packages/haskell-crypto.scm (ghc-cryptonite-conduit): New variable.
---
 gnu/packages/haskell-crypto.scm | 39 +++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index c92dec9932..1d56327d29 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -838,3 +838,42 @@  implementation of SSL.")
     (description "This library contains io-streams routines for secure
 networking using OpenSSL (by way of HsOpenSSL).")
     (license license:bsd-3)))
+
+(define-public ghc-cryptonite-conduit
+  (package
+   (name "ghc-cryptonite-conduit")
+   (version "0.2.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://hackage.haskell.org/package/cryptonite-conduit/cryptonite-conduit-"
+           version
+           ".tar.gz"))
+     (sha256
+      (base32
+       "1bldcmda4xh52mw1wfrjljv8crhw3al7v7kv1j0vidvr7ymnjpbh"))))
+   (build-system haskell-build-system)
+   (inputs
+    `(("ghc-conduit" ,ghc-conduit)
+      ("ghc-conduit-extra" ,ghc-conduit-extra)
+      ("ghc-cryptonite" ,ghc-cryptonite)
+      ("ghc-exceptions" ,ghc-exceptions)
+      ("ghc-memory" ,ghc-memory)
+      ("ghc-resourcet" ,ghc-resourcet)))
+   (native-inputs
+    `(("ghc-conduit-combinators"
+       ,ghc-conduit-combinators)
+      ("ghc-tasty" ,ghc-tasty)
+      ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+      ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+   (arguments
+    `(#:cabal-revision
+      ("1"
+       "1hh2nzfz4qpxgivfilgk4ll416lph8b2fdkzpzrmqfjglivydfmz")))
+   (home-page
+    "https://github.com/haskell-crypto/cryptonite-conduit")
+   (synopsis "Cryptonite bridge for conduit")
+   (description
+    "This package provides a conduit version for hash and hmac.")
+   (license license:bsd-3)))