diff mbox series

[bug#44940,2/4] gnu: go-github-com-mattn-go-colorable: Update to 0.1.8.

Message ID 20201129050802.47551-1-joseph@lafreniere.xyz
State Accepted
Headers show
Series [bug#44940,1/4] gnu: Add go-github-com-nwidger-jsoncolor. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

LaFreniere, Joseph Nov. 29, 2020, 5:08 a.m. UTC
* gnu/packages/golang.scm (go-github-com-mattn-go-colorable): Update to 0.1.8.
---
 gnu/packages/golang.scm | 48 ++++++++++++++++++++---------------------
 1 file changed, 23 insertions(+), 25 deletions(-)

Comments

Ludovic Courtès Dec. 23, 2020, 4:07 p.m. UTC | #1
Hi,

Joseph LaFreniere <joseph@lafreniere.xyz> skribis:

> * gnu/packages/golang.scm (go-github-com-mattn-go-colorable): Update to 0.1.8.

Applied.

> * gnu/packages/golang.scm (go-github-com-tomnomnom-gron): New variable.

Applied, but I changed the ‘name’ field to ‘gron’, as is commonly done
for applications.

> * gnu/packages/golang.scm (gron): New variable.

This patch has no effect; perhaps what you wanted is for the package
name to be ‘gron’, like I did above?

Thanks,
Ludo’.
LaFreniere, Joseph Dec. 27, 2020, 8:20 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:
>> * gnu/packages/golang.scm (go-github-com-tomnomnom-gron): New 
>> variable.
>
> Applied, but I changed the ‘name’ field to ‘gron’, as is 
> commonly done
> for applications.

Noted.  I had originally provided the full, Go package-style name 
in the event that gron were ever used as a dependency by another 
Go package.

>> * gnu/packages/golang.scm (gron): New variable.
>
> This patch has no effect; perhaps what you wanted is for the 
> package
> name to be ‘gron’, like I did above?

Yes, that was my intent.

Thank you for merging!

--
Joseph LaFreniere
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 72f43efd8a..cb7fe6e3bb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1965,32 +1965,30 @@  terminal.")
     (license license:expat)))
 
 (define-public go-github-com-mattn-go-colorable
-  (let ((commit "efa589957cd060542a26d2dd7832fd6a6c6c3ade")
-        (revision "0"))
-    (package
-      (name "go-github-com-mattn-go-colorable")
-      (version (git-version "0.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/mattn/go-colorable")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0kshi4hvm0ayrsxqxy0599iv81kryhd2fn9lwjyczpj593cq069r"))))
-      (build-system go-build-system)
-      (native-inputs
-       `(("go-github-com-mattn-go-isatty"
-          ,go-github-com-mattn-go-isatty)))
-      (arguments
-       '(#:import-path "github.com/mattn/go-colorable"))
-      (home-page "https://github.com/mattn/go-colorable")
-      (synopsis "Handle ANSI color escapes on Windows")
-      (description "This package provides @code{colorable}, a module that
+  (package
+    (name "go-github-com-mattn-go-colorable")
+    (version "0.1.8")
+    (home-page "https://github.com/mattn/go-colorable")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0q34zqwbnls72md8q8mhj368s7p3i4xspvs3rk8fs76s0pn7dr2l"))))
+    (build-system go-build-system)
+    (native-inputs
+     `(("go-github-com-mattn-go-isatty"
+        ,go-github-com-mattn-go-isatty)))
+    (arguments
+     '(#:import-path "github.com/mattn/go-colorable"))
+    (synopsis "Handle ANSI color escapes on Windows")
+    (description "This package provides @code{colorable}, a module that
 makes it possible to handle ANSI color escapes on Windows.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public go-github-com-mattn-go-pointer
   (let ((commit "a0a44394634f41e4992b173b24f14fecd3318a67")