diff mbox series

[bug#44902] gnu: loko: Update to 0.7.0

Message ID 20201127145444.16805-1-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#44902] gnu: loko: Update to 0.7.0 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze Nov. 27, 2020, 2:54 p.m. UTC
* gnu/packages/loko.scm (loko-scheme): Update to 0.7.0
---
 gnu/packages/loko.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Kei Kebreau Nov. 27, 2020, 8:56 p.m. UTC | #1
Hi Martin!

Thanks for submitting this patch.  I noticed a section of the
loko-scheme package mentions that some R7RS tests failed as of version
0.6.0.  Are these tests fixed and runnable as of version 0.7.0?

Kei


Martin Becze <mjbecze@riseup.net> writes:

> * gnu/packages/loko.scm (loko-scheme): Update to 0.7.0
> ---
>  gnu/packages/loko.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
> index f6699877f7..737f7250fa 100644
> --- a/gnu/packages/loko.scm
> +++ b/gnu/packages/loko.scm
> @@ -29,7 +29,7 @@
>  (define-public loko-scheme
>    (package
>      (name "loko-scheme")
> -    (version "0.6.0")
> +    (version "0.7.0")
>      (source
>       (origin
>         (method git-fetch)
> @@ -37,7 +37,7 @@
>               (url "https://gitlab.com/weinholt/loko")
>               (commit (string-append "v" version))))
>         (sha256
> -        (base32 "019jlh3lywy912cfz689c9fxgf4bi5700i9k04g7sl5w5gchj36m"))
> +        (base32 "1441aarw3vy14zdxyab495ag2fch04v4j89krhbqnqfkz6mdi0vy"))
>         (file-name (git-file-name name version))))
>      (build-system gnu-build-system)
>      (arguments
Martin Becze Nov. 28, 2020, 3:27 p.m. UTC | #2
The tests are still a work in progress.

On 11/27/20 2:56 PM, Kei Kebreau wrote:
> Hi Martin!
> 
> Thanks for submitting this patch.  I noticed a section of the
> loko-scheme package mentions that some R7RS tests failed as of version
> 0.6.0.  Are these tests fixed and runnable as of version 0.7.0?
> 
> Kei
> 
> 
> Martin Becze <mjbecze@riseup.net> writes:
> 
>> * gnu/packages/loko.scm (loko-scheme): Update to 0.7.0
>> ---
>>   gnu/packages/loko.scm | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
>> index f6699877f7..737f7250fa 100644
>> --- a/gnu/packages/loko.scm
>> +++ b/gnu/packages/loko.scm
>> @@ -29,7 +29,7 @@
>>   (define-public loko-scheme
>>     (package
>>       (name "loko-scheme")
>> -    (version "0.6.0")
>> +    (version "0.7.0")
>>       (source
>>        (origin
>>          (method git-fetch)
>> @@ -37,7 +37,7 @@
>>                (url "https://gitlab.com/weinholt/loko")
>>                (commit (string-append "v" version))))
>>          (sha256
>> -        (base32 "019jlh3lywy912cfz689c9fxgf4bi5700i9k04g7sl5w5gchj36m"))
>> +        (base32 "1441aarw3vy14zdxyab495ag2fch04v4j89krhbqnqfkz6mdi0vy"))
>>          (file-name (git-file-name name version))))
>>       (build-system gnu-build-system)
>>       (arguments
Kei Kebreau Nov. 29, 2020, 4:37 a.m. UTC | #3
Okay, I've amended the comment at the top of the arguments section and
pushed the commit to master as 40352788de.  Thanks again!

P.S.: I'm seeing now that "gnu: loko..." should have been "gnu: loko-scheme..."
in the first line of the commit message, but it's a bit late now!

Martin Becze <mjbecze@riseup.net> writes:

> The tests are still a work in progress.
>
> On 11/27/20 2:56 PM, Kei Kebreau wrote:
>> Hi Martin!
>> Thanks for submitting this patch.  I noticed a section of the
>> loko-scheme package mentions that some R7RS tests failed as of version
>> 0.6.0.  Are these tests fixed and runnable as of version 0.7.0?
>> Kei
>> 
>> Martin Becze <mjbecze@riseup.net> writes:
>>
diff mbox series

Patch

diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
index f6699877f7..737f7250fa 100644
--- a/gnu/packages/loko.scm
+++ b/gnu/packages/loko.scm
@@ -29,7 +29,7 @@ 
 (define-public loko-scheme
   (package
     (name "loko-scheme")
-    (version "0.6.0")
+    (version "0.7.0")
     (source
      (origin
        (method git-fetch)
@@ -37,7 +37,7 @@ 
              (url "https://gitlab.com/weinholt/loko")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "019jlh3lywy912cfz689c9fxgf4bi5700i9k04g7sl5w5gchj36m"))
+        (base32 "1441aarw3vy14zdxyab495ag2fch04v4j89krhbqnqfkz6mdi0vy"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments