diff mbox series

[bug#43976] Chicken build system + some example eggs

Message ID 20201124212254.0c69b459@riseup.net
State Accepted
Headers show
Series [bug#43976] Chicken build system + some example eggs | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Nov. 24, 2020, 8:22 p.m. UTC
On Mon, 23 Nov 2020 00:12:41 +0100
raingloom <raingloom@riseup.net> wrote:

> On Sat, 21 Nov 2020 21:45:43 +0100
> raingloom <raingloom@riseup.net> wrote:
> 
> > On Fri, 20 Nov 2020 05:51:17 +0100
> > raingloom <raingloom@riseup.net> wrote:
> >   
> > > Possibly more important: I noticed some warnings in some builds
> > > about cp(1). So far it hasn't caused any issues. Gonna fix this,
> > > then I think it'll be mergeable.    
> > 
> > Seems to be a srfi-18 specific issue, so I'm calling
> > chicken-build-system final for now. You can merge it if it stands up
> > to a review.
> > The other eggs also seem fine, srfi-18 just has a somewhat shoddily
> > written auxiliary build script to generate some type information,
> > probably based on the current Chicken version? I'm not sure what
> > it's doing to be honest. It doesn't fail to build because the script
> > doesn't check for errors, which is why it took a while to notice it.
> > 
> > This is why we always `set -e` in our Bash scripts, kids.
> > 
> > Anyways, all other eggs seem to be fine, and none of them depend on
> > srfi-18.  
> 
> Forgot to actually send the modified patch :D
> The others should be unchanged.

*facepalm* i somehow messed up the parens in that one. maybe i didn't
have Paredit on or something??? here's the fixed version.
but yeah, with this, it should be complete.

Comments

Ludovic Courtès Nov. 27, 2020, 9:09 a.m. UTC | #1
Hi raingloom!

raingloom <raingloom@riseup.net> skribis:

> From 2ba52705cf909590a428ea598dfdf1c61ada6a8c Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Mon, 12 Oct 2020 04:11:59 +0200
> Subject: [PATCH 01/20] gnu: Added search paths for Chicken Scheme.
>
> * gnu/packages/chicken.scm (chicken): Added search paths
>   [native-search-paths]: added CHICKEN_REPOSITORY_PATH and a comment about
>                          CHICKEN_INCLUDE_PATH.

[...]

> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "CHICKEN_REPOSITORY_PATH")
> +            ;; TODO extract binary version into a module level definition.
> +            (files (list "var/lib/chicken/11")))))
> +    ;; the use of this variable is unclear. the online docs don't even
> +    ;; mention it. i'm leaving it in as a comment for now, in case
> +    ;; something breaks.
> +    ;; (search-path-specification
> +    ;;  (variable "CHICKEN_INCLUDE_PATH")
> +    ;;  (files '("share")))

I think you can remove the comment here; presumably we now know that
CHICKEN_REPOSITORY_PATH is the one that matters.  :-)

Could you please ensure that earlier comments notably at
<https://issues.guix.gnu.org/43976#1> have been taken into account, that
the SRFI packages still build and have a layout consistent with the
var/lib/chicken/11 search path above, and send a v2 of the whole series?

Thanks in advance!

Ludo’.
diff mbox series

Patch

From 2ba52705cf909590a428ea598dfdf1c61ada6a8c Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Mon, 12 Oct 2020 04:11:59 +0200
Subject: [PATCH 01/20] gnu: Added search paths for Chicken Scheme.

* gnu/packages/chicken.scm (chicken): Added search paths
  [native-search-paths]: added CHICKEN_REPOSITORY_PATH and a comment about
                         CHICKEN_INCLUDE_PATH.
---
 gnu/packages/chicken.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 729cf25a6c..42232ec3b8 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -59,6 +59,17 @@ 
 
        ;; Parallel builds are not supported, as noted in README.
        #:parallel-build? #f))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CHICKEN_REPOSITORY_PATH")
+            ;; TODO extract binary version into a module level definition.
+            (files (list "var/lib/chicken/11")))))
+    ;; the use of this variable is unclear. the online docs don't even
+    ;; mention it. i'm leaving it in as a comment for now, in case
+    ;; something breaks.
+    ;; (search-path-specification
+    ;;  (variable "CHICKEN_INCLUDE_PATH")
+    ;;  (files '("share")))
     (propagated-inputs `(("gcc-toolchain" ,gcc-toolchain)))
     (home-page "https://www.call-cc.org/")
     (synopsis "R5RS Scheme implementation that compiles native code via C")
-- 
2.29.2