diff mbox series

[bug#43976] Chicken build system + some example eggs

Message ID 20201123001241.024b7a08@riseup.net
State Accepted
Headers show
Series [bug#43976] Chicken build system + some example eggs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Nov. 22, 2020, 11:12 p.m. UTC
On Sat, 21 Nov 2020 21:45:43 +0100
raingloom <raingloom@riseup.net> wrote:

> On Fri, 20 Nov 2020 05:51:17 +0100
> raingloom <raingloom@riseup.net> wrote:
> 
> > Possibly more important: I noticed some warnings in some builds
> > about cp(1). So far it hasn't caused any issues. Gonna fix this,
> > then I think it'll be mergeable.  
> 
> Seems to be a srfi-18 specific issue, so I'm calling
> chicken-build-system final for now. You can merge it if it stands up
> to a review.
> The other eggs also seem fine, srfi-18 just has a somewhat shoddily
> written auxiliary build script to generate some type information,
> probably based on the current Chicken version? I'm not sure what it's
> doing to be honest. It doesn't fail to build because the script
> doesn't check for errors, which is why it took a while to notice it.
> 
> This is why we always `set -e` in our Bash scripts, kids.
> 
> Anyways, all other eggs seem to be fine, and none of them depend on
> srfi-18.

Forgot to actually send the modified patch :D
The others should be unchanged.
diff mbox series

Patch

From eeb306cb76ea8e6c1487df0c13c7539d69202e3f Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Mon, 12 Oct 2020 04:11:59 +0200
Subject: [PATCH 01/20] gnu: Added search paths for Chicken Scheme.

* gnu/packages/chicken.scm (chicken): Added search paths
  [native-search-paths]: added CHICKEN_REPOSITORY_PATH and a comment about
                         CHICKEN_INCLUDE_PATH.
---
 gnu/packages/chicken.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 729cf25a6c..8a7f2a9eaf 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -59,6 +59,17 @@ 
 
        ;; Parallel builds are not supported, as noted in README.
        #:parallel-build? #f))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CHICKEN_REPOSITORY_PATH")
+            ;; TODO extract binary version into a module level definition.
+            (files (list "var/lib/chicken/11")))
+           ;; the use of this variable is unclear. the online docs don't even
+           ;; mention it. i'm leaving it in as a comment for now, in case
+           ;; something breaks.
+           ;; (search-path-specification
+           ;;  (variable "CHICKEN_INCLUDE_PATH")
+           ;;  (files '("share")))))
     (propagated-inputs `(("gcc-toolchain" ,gcc-toolchain)))
     (home-page "https://www.call-cc.org/")
     (synopsis "R5RS Scheme implementation that compiles native code via C")
-- 
2.29.2