diff mbox series

[bug#44806,staging,4/6] gnu: Update and deprecate gst-transcoder.

Message ID 20201122203625.1347-4-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add Pitivi | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Nov. 22, 2020, 8:36 p.m. UTC
As of 1.18, gst-transcoder is part of gst-plugins-bad.

* gnu/packages/video.scm (gst-transcoder): Move from here...
* gnu/packages/gstreamer.scm (gst-transcoder): ... to here.
Redefine in terms of gst-plugins-bad and deprecate in favor of it.
---
 gnu/packages/gstreamer.scm |  7 +++++++
 gnu/packages/video.scm     | 28 ----------------------------
 2 files changed, 7 insertions(+), 28 deletions(-)

Comments

Leo Famulari Dec. 15, 2020, 7:21 a.m. UTC | #1
On Sun, Nov 22, 2020 at 09:36:23PM +0100, Leo Prikler wrote:
> As of 1.18, gst-transcoder is part of gst-plugins-bad.
> 
> * gnu/packages/video.scm (gst-transcoder): Move from here...
> * gnu/packages/gstreamer.scm (gst-transcoder): ... to here.
> Redefine in terms of gst-plugins-bad and deprecate in favor of it.

This is good but I think we can just remove gst-transcoder, right? I
don't see any packages using it in Guix.
Leo Prikler Dec. 15, 2020, 8:45 a.m. UTC | #2
Am Dienstag, den 15.12.2020, 02:21 -0500 schrieb Leo Famulari:
> On Sun, Nov 22, 2020 at 09:36:23PM +0100, Leo Prikler wrote:
> > As of 1.18, gst-transcoder is part of gst-plugins-bad.
> > 
> > * gnu/packages/video.scm (gst-transcoder): Move from here...
> > * gnu/packages/gstreamer.scm (gst-transcoder): ... to here.
> > Redefine in terms of gst-plugins-bad and deprecate in favor of it.
> 
> This is good but I think we can just remove gst-transcoder, right? I
> don't see any packages using it in Guix.
That may be the case, but I've opted to inform users about its
deprecation first.  It was probably packaged in an earlier effort to
add pitivi, but who knows whether someone might be having it in their
profile for some personal project?
Leo Famulari Dec. 15, 2020, 9:21 p.m. UTC | #3
On Tue, Dec 15, 2020 at 09:45:44AM +0100, Leo Prikler wrote:
> Am Dienstag, den 15.12.2020, 02:21 -0500 schrieb Leo Famulari:
> > On Sun, Nov 22, 2020 at 09:36:23PM +0100, Leo Prikler wrote:
> > > As of 1.18, gst-transcoder is part of gst-plugins-bad.
> > > 
> > > * gnu/packages/video.scm (gst-transcoder): Move from here...
> > > * gnu/packages/gstreamer.scm (gst-transcoder): ... to here.
> > > Redefine in terms of gst-plugins-bad and deprecate in favor of it.
> > 
> > This is good but I think we can just remove gst-transcoder, right? I
> > don't see any packages using it in Guix.
> That may be the case, but I've opted to inform users about its
> deprecation first.  It was probably packaged in an earlier effort to
> add pitivi, but who knows whether someone might be having it in their
> profile for some personal project?
 
Okay, that makes sense. We should remember to complete the process and
remove the package eventually :)
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 4756508f2e..f584576f2a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -925,6 +925,13 @@  given, also pass them to the build system instead of the ones used by PKG."
                    (("'auto'") "'disabled'"))
                  #t)))))))))
 
+(define-public gst-transcoder
+  (deprecated-package
+   "gst-transcoder"
+   (gst-plugins/selection gst-plugins-bad
+                          #:plugins '("transcoder")
+                          #:configure-flags '("-Dintrospection=enabled"))))
+
 (define-public python-gst
   (package
     (name "python-gst")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 21380a9677..0278604fb2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3962,34 +3962,6 @@  tools for styling them, including a built-in real-time video preview.")
    ; by upstream). See https://github.com/Aegisub/Aegisub/blob/master/LICENCE
    ; src/MatroskaParser.(c|h) is under bsd-3 with permission from the author
 
-(define-public gst-transcoder
-  (package
-    (name "gst-transcoder")
-    (version "1.12.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/pitivi/gst-transcoder")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0nw1zykqc6c8xs3ri55pm00pwyz93z4y4nd880apfiwj7yv5p3az"))))
-    (build-system meson-build-system)
-    (inputs
-     `(("gobject-introspection" ,gobject-introspection)
-       ("glib" ,glib)
-       ("gstreamer" ,gstreamer)
-       ("gst-plugins-base" ,gst-plugins-base)))
-    (native-inputs
-     `(("python" ,python)
-       ("pkg-config" ,pkg-config)))
-    (home-page "https://github.com/pitivi/gst-transcoder/")
-    (synopsis "GStreamer Transcoding API")
-    (description "GStreamer Transcoding API")
-    (license license:lgpl2.1)))
-
 (define-public gavl
   (package
     (name "gavl")