diff mbox series

[bug#44788] gnu: Add python-baycomp.

Message ID 20201122030525.52307-1-monego@posteo.net
State Accepted
Headers show
Series [bug#44788] gnu: Add python-baycomp. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 22, 2020, 3:05 a.m. UTC
* gnu/packages/python-science.scm (python-baycomp): New variable.
---
 gnu/packages/python-science.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou Nov. 24, 2020, 1:02 p.m. UTC | #1
Hello,

Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/python-science.scm (python-baycomp): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 101c8fb640..8d06f4f962 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -439,6 +439,32 @@  doing practical, real world data analysis in Python.")
 written in C.")
     (license license:bsd-2)))
 
+(define-public python-baycomp
+  (package
+    (name "python-baycomp")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "baycomp" version))
+       (sha256
+        (base32 "1c1354a7b3g8slychjgyjxqdm8z40z9kviyl9n4g9kfpdg0p4d64"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-matplotlib" ,python-matplotlib)
+       ("python-numpy" ,python-numpy)
+       ("python-scipy" ,python-scipy)))
+    (home-page "https://github.com/janezd/baycomp")
+    (synopsis "Library for comparison of Bayesian classifiers")
+    (description
+     "@code{baycomp} is a library for Bayesian comparison of classifiers.
+Functions in the library compare two classifiers on one or on multiple data
+sets.  They compute three probabilities: the probability that the first
+classifier has higher scores than the second, the probability that differences
+are within the region of practical equivalence (rope), or that the second
+classifier has higher scores.")
+    (license license:expat)))
+
 (define-public python-xarray
   (package
     (name "python-xarray")