diff mbox series

[bug#44771] gnu: Properly use $QTWEBENGINEPROCESS_PATH

Message ID 20201121101102.25373-1-sarg@sarg.org.ru
State Accepted
Headers show
Series [bug#44771] gnu: Properly use $QTWEBENGINEPROCESS_PATH | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sergey Trofimov Nov. 21, 2020, 10:11 a.m. UTC
---
 gnu/packages/ebook.scm        | 2 +-
 gnu/packages/web-browsers.scm | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Christopher Baines Nov. 28, 2020, 4:34 p.m. UTC | #1
Sergey Trofimov <sarg@sarg.org.ru> writes:

> ---
>  gnu/packages/ebook.scm        | 2 +-
>  gnu/packages/web-browsers.scm | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
> index 1609a631b7..e80ad45383 100644
> --- a/gnu/packages/ebook.scm
> +++ b/gnu/packages/ebook.scm
> @@ -281,7 +281,7 @@
>                    (lambda (binary)
>                      (wrap-program binary
>                        ;; Make QtWebEngineProcess available.
> -                      `("QTWEBENGINEPROCESS_PATH" ":" =
> +                      `("QTWEBENGINEPROCESS_PATH" =
>                          ,(list (string-append
>                                  qtwebengine
>                                  "/lib/qt5/libexec/QtWebEngineProcess")))))
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index 51af66ef54..bf1d45e5cc 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -538,7 +538,7 @@ interface.")
>                                        (assoc-ref inputs "qtwebengine")
>                                        "/lib/qt5/libexec/QtWebEngineProcess")))
>                 (wrap-program bin
> -                 `("QTWEBENGINEPROCESS_PATH" ":" prefix (,qt-process-path)))
> +                 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
>                 #t))))))
>      (home-page "https://qutebrowser.org/")
>      (synopsis "Minimal, keyboard-focused, vim-like web browser")

Thanks, I split this in to two commits, wrote commit messages and pushed
to master in f4d139d02f0b0404540b74f3249de050b519b880.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 1609a631b7..e80ad45383 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -281,7 +281,7 @@ 
                   (lambda (binary)
                     (wrap-program binary
                       ;; Make QtWebEngineProcess available.
-                      `("QTWEBENGINEPROCESS_PATH" ":" =
+                      `("QTWEBENGINEPROCESS_PATH" =
                         ,(list (string-append
                                 qtwebengine
                                 "/lib/qt5/libexec/QtWebEngineProcess")))))
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 51af66ef54..bf1d45e5cc 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -538,7 +538,7 @@  interface.")
                                       (assoc-ref inputs "qtwebengine")
                                       "/lib/qt5/libexec/QtWebEngineProcess")))
                (wrap-program bin
-                 `("QTWEBENGINEPROCESS_PATH" ":" prefix (,qt-process-path)))
+                 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
                #t))))))
     (home-page "https://qutebrowser.org/")
     (synopsis "Minimal, keyboard-focused, vim-like web browser")